zoukankan      html  css  js  c++  java
  • HDU 1027 Ignatius and the Princess II (产生第m大的排列,STLmap中的next_permutation(array,array+n);)

    Ignatius and the Princess II

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2272    Accepted Submission(s): 1371


    Problem Description
    Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

    "Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
    Can you help Ignatius to solve this problem?
     
    Input
    The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
     
    Output
    For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
     
    Sample Input
    6 4 11 8
     
    Sample Output
    1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10
     
    Author
    Ignatius.L
     
     
    用法见下列链接:、
     
     
    这个函数很好啊!!!!
    #include<stdio.h>
    #include<map>
    #include<iostream>
    using namespace std;
    const int MAXN=1010;
    int a[MAXN];
    int main()
    {
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
    for(int i=1;i<=n;i++) a[i]=i;
    int num=1;
    while(num<m)
    {
    next_permutation(a+1,a+1+n);
    num++;
    }
    for(int i=1;i<n;i++)
    printf("%d ",a[i]);
    printf("%d\n",a[n]);
    }
    return 0;
    }
     
  • 相关阅读:
    angularjs学习笔记—工具方法
    js日期格式转换的相关问题探讨
    vue路由原理剖析
    如何减少UI设计师产品与前端工程师的沟通成本
    前端优化带来的思考,浅谈前端工程化
    前端入门方法
    自写juqery插件实现左右循环滚动效果图
    前端大综合
    前端收集
    如何在代码中减少if else语句的使用
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2424483.html
Copyright © 2011-2022 走看看