zoukankan      html  css  js  c++  java
  • HDU 1211 RSA(数列题目)

    RSA

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 706    Accepted Submission(s): 524


    Problem Description
    RSA is one of the most powerful methods to encrypt data. The RSA algorithm is described as follow:

    > choose two large prime integer p, q
    > calculate n = p × q, calculate F(n) = (p - 1) × (q - 1)
    > choose an integer e(1 < e < F(n)), making gcd(e, F(n)) = 1, e will be the public key
    > calculate d, making d × e mod F(n) = 1 mod F(n), and d will be the private key

    You can encrypt data with this method :

    C = E(m) = me mod n

    When you want to decrypt data, use this method :

    M = D(c) = cd mod n

    Here, c is an integer ASCII value of a letter of cryptograph and m is an integer ASCII value of a letter of plain text.

    Now given p, q, e and some cryptograph, your task is to "translate" the cryptograph into plain text.
     
    Input
    Each case will begin with four integers p, q, e, l followed by a line of cryptograph. The integers p, q, e, l will be in the range of 32-bit integer. The cryptograph consists of l integers separated by blanks.
     
    Output
    For each case, output the plain text in a single line. You may assume that the correct result of plain text are visual ASCII letters, you should output them as visualable letters with no blank between them.
     
    Sample Input
    101 103 7 11 7716 7746 7497 126 8486 4708 7746 623 7298 7357 3239
     
    Sample Output
    I-LOVE-ACM.
     
    Author
    JGShining(极光炫影)
     
    Source
     
    Recommend
    Eddy
     
     
     
    很可耻的,
    枚举一下竟然AC了
     
     
    #include<stdio.h>
    int main()
    {
    int p,q,e,l;
    int c;
    int n;
    int fn;
    int temp;
    int d;
    while(scanf("%d%d%d%d",&p,&q,&e,&l)!=EOF)
    {
    n=p*q;
    fn=(p-1)*(q-1);
    d=1;
    while(d*e%fn!=1) d++;
    for(int i=0;i<l;i++)
    {
    scanf("%d",&c);
    temp=1;
    for(int j=0;j<d;j++)
    {
    temp=(temp*c)%n;
    }
    printf("%c",temp);
    }
    printf("\n");
    }
    return 0;
    }
     
    太暴力了。其实应该用扩展欧几里德法去解方程的
     
  • 相关阅读:
    Unique Encryption Keys 暴力学习map,vector 函数
    hdu 1250 Hat's Fibonacci
    匈牙利算法模板 图的二分匹配 hdu 2063 过山车
    hdu 4260 汉诺塔问题 The End of The World
    各种常见文件的hex文件头
    Ubuntu & node.js
    Linux周期性任务的执行指令配置
    MySQL各版本的性能特性(从4.0版本开始)
    Tsung 1.5.0 增加对 WebSocket 和 BOSH 的支持
    ShowSlow+Yslow环境搭建
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2433957.html
Copyright © 2011-2022 走看看