zoukankan      html  css  js  c++  java
  • POJ 1113 Wall (凸包)

    Wall
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 21502   Accepted: 7048

    Description

    Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.

    Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.

    The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.

    Input

    The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.

    Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

    Output

    Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

    Sample Input

    9 100
    200 400
    300 400
    300 300
    400 300
    400 400
    500 400
    500 200
    350 200
    200 200

    Sample Output

    1628

    Hint

    结果四舍五入就可以了

    Source

     
     
    这道题的答案是凸包周长加上一个圆周长,即包围凸包的一个圆角多边形,但是没弄明白那些圆角加起来为什么恰好是一个圆。每个圆角是以凸包对应的顶点为圆心,给定的L为半径,与相邻两条边的切点之间的一段圆弧。每个圆弧的两条半径夹角与对应的凸包的内角互补。假设凸包有n条边,则所有圆弧角之和为180°*n-180°*(n-2)=360°。故,围墙周长为=n条平行于凸包的线段+n条圆弧的长度=凸包周长+围墙离城堡距离L为半径的圆周长。
     
    程序如下:
    自己写的凸包模版,Graham,细节处修改了下。
    #include<stdio.h>
    #include<math.h>
    #include<algorithm>
    #include<iostream>
    using namespace std;
    const int MAXN=1000;
    const double PI=acos(-1.0);
    
    struct point
    {
        int x,y;
    };
    point list[MAXN];
    int stack[MAXN],top;
    
    int cross(point p0,point p1,point p2) //计算叉积  p0p1 X p0p2 
    {
        return (p1.x-p0.x)*(p2.y-p0.y)-(p1.y-p0.y)*(p2.x-p0.x);
    }    
    double dis(point p1,point p2)  //计算 p1p2的 距离 
    {
        return sqrt((double)(p2.x-p1.x)*(p2.x-p1.x)+(p2.y-p1.y)*(p2.y-p1.y));
    }    
    bool cmp(point p1,point p2) //极角排序函数 , 角度相同则距离小的在前面 
    {
        int tmp=cross(list[0],p1,p2);
        if(tmp>0) return true;
        else if(tmp==0&&dis(list[0],p1)<dis(list[0],p2)) return true;
        else return false;
    }    
    void init(int n) //输入,并把  最左下方的点放在 list[0]  。并且进行极角排序 
    {
        int i,k;
        point p0;
        scanf("%d%d",&list[0].x,&list[0].y);
        p0.x=list[0].x;
        p0.y=list[0].y;
        k=0;
        for(i=1;i<n;i++)
        {
            scanf("%d%d",&list[i].x,&list[i].y);
            if( (p0.y>list[i].y) || ((p0.y==list[i].y)&&(p0.x>list[i].x)) )
            {
                p0.x=list[i].x;
                p0.y=list[i].y;
                k=i;
            }    
        }    
        list[k]=list[0];
        list[0]=p0;
        
        sort(list+1,list+n,cmp);
    }     
    
    void graham(int n)
    {
        int i;
        if(n==1) {top=0;stack[0]=0;}
        if(n==2)
        {
            top=1;
            stack[0]=0;
            stack[1]=1;
        }    
        if(n>2)
        {
            for(i=0;i<=1;i++) stack[i]=i;
            top=1;
            
            for(i=2;i<n;i++)
            {
                while(top>0&&cross(list[stack[top-1]],list[stack[top]],list[i])<=0) top--;
                top++;
                stack[top]=i;
            }    
        }    
    }    
    
    int main()
    {
        int N,L;
        while(scanf("%d%d",&N,&L)!=EOF)
        {
            init(N);
            graham(N);
            double res=0;
            for(int i=0;i<top;i++)
              res+=dis(list[stack[i]],list[stack[i+1]]);
            res+=dis(list[stack[0]],list[stack[top]]);
            
            res+=2*PI*L;
            printf("%d\n",(int)(res+0.5));
            
        }    
        return 0;
    }  
     
  • 相关阅读:
    clearfix 清除浮动的问题
    python第四十五课——继承性之多继承
    Linux基础第六课——grep|awk|sort|uniq
    Linux基础第五课——用户管理
    Linux基础第四课——文件操作
    Linux第三课——目录操作
    Linux基础第二课——系统架构
    Linux基础第一课——基础知识了解
    01 http协议概念及工作流程
    18- php Redis扩展编译
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2445633.html
Copyright © 2011-2022 走看看