zoukankan      html  css  js  c++  java
  • HDU 1059 Dividing(多重背包)

    Dividing

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 7678    Accepted Submission(s): 2095


    Problem Description
    Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value.
    Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
     
    Input
    Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000.

    The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
     
    Output
    For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''.

    Output a blank line after each test case.
     
    Sample Input
    1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
     
    Sample Output
    Collection #1: Can't be divided. Collection #2: Can be divided.
     
    Source
     
    Recommend
    JGShining
     
    //多重背包
    //HDU 1059
    //题意:价值分别为1,2,3,4,5,6的物品的个数分别为 a[1],a[2],````a[6]
    //问能不能分成两堆价值相等的
     
    #include<stdio.h>
    #include<string.h>
    int a[7];
    int f[120005];
    int v,k;
    void ZeroOnePack(int cost,int weight)//cost 为费用, weight 为价值 
    {
        for(int i=v;i>=cost;i--)
           if(f[i-cost]+weight>f[i]) f[i]=f[i-cost]+weight;
    }    
    void CompletePack(int cost,int weight)
    {
        for(int i=cost;i<=v;i++)
            if(f[i-cost]+weight>f[i]) f[i]=f[i-cost]+weight;
    }         
    void MultiplePack(int cost ,int weight,int amount)
    {
        if(cost*amount>=v) CompletePack(cost,weight);
        else
        {
            for(int k=1;k<amount;)
            {
                ZeroOnePack(k*cost,k*weight);
                amount-=k;
                k<<=1;
            }    
            ZeroOnePack(amount*cost,amount*weight);
        }    
    }    
    int main()
    {
        int tol;
        int iCase=0;
        while(1)
        {
            iCase++;
            tol=0;
            for(int i=1;i<7;i++)
            {
                scanf("%d",&a[i]);
                tol+=a[i]*i;//总价值数 
            }  
            if(tol==0) break;
            if(tol%2==1)
            {
                printf("Collection #%d:\nCan't be divided.\n\n",iCase);
                continue;
            }      
            else
            {
                v=tol/2;
                memset(f,0,sizeof(f));
                for(int i=1;i<7;i++)
                  MultiplePack(i,i,a[i]);
                if(f[v]==v) 
                  printf("Collection #%d:\nCan be divided.\n\n",iCase);
                else printf("Collection #%d:\nCan't be divided.\n\n",iCase);
            }    
        }    
        return 0;    
    }    
  • 相关阅读:
    Fiddler 教程
    Snippet Compiler——代码段编译工具
    HTML5 Audio时代的MIDI音乐文件播放
    sql 数据库 庞大数据量 需要分表
    使用LINQ查询非泛型类型
    找出numpy array数组的最值及其索引
    list的*运算使用过程中遇到的问题
    4.keras实现-->生成式深度学习之用GAN生成图像
    np.repeat 与 np.tile
    pandas中的axis=0,axis=1,傻傻分不清楚
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2493602.html
Copyright © 2011-2022 走看看