zoukankan      html  css  js  c++  java
  • HDU 1035 Robot Motion(简单题,模拟)

    Robot Motion

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3466    Accepted Submission(s): 1608


    Problem Description


    A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

    N north (up the page)
    S south (down the page)
    E east (to the right on the page)
    W west (to the left on the page)

    For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

    Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

    You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.
     
    Input
    There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
     
    Output
    For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
     
    Sample Input
    3 6 5 NEESWE WWWESS SNWWWW 4 5 1 SESWE EESNW NWEEN EWSEN 0 0
     
    Sample Output
    10 step(s) to exit 3 step(s) before a loop of 8 step(s)
     
    Source
     
     
    简单模拟,,,,
    水题
     
     
    #include<stdio.h>
    #include<string.h>
    #include<string.h>
    
    const int MAXN=1000;
    char map[MAXN][MAXN];
    int t[MAXN][MAXN];
    int main()
    {
        int n,m,k;
        int x,y;
        while(scanf("%d%d",&n,&m))
        {
            if(n==0&&m==0) break;
            scanf("%d",&k);
            for(int i=0;i<n;i++) scanf("%s",&map[i]);
            x=0;
            y=k-1;
            memset(t,0,sizeof(t));
            t[x][y]=1;
            while(1)
            {
                if(map[x][y]=='W')
                {
                    y--;
                    if(y<0) 
                    {
                        printf("%d step(s) to exit\n",t[x][y+1]);
                        break;
                    }    
                    if(t[x][y]!=0)
                    {
                        printf("%d step(s) before a loop of %d step(s)\n",t[x][y]-1,t[x][y+1]-t[x][y]+1);
                        break;
                    }    
                    t[x][y]=t[x][y+1]+1;
                }    
                else if(map[x][y]=='E')
                {
                    y++;
                    if(y>=m)
                    {
                        printf("%d step(s) to exit\n",t[x][y-1]);
                        break;
                    }    
                    if(t[x][y]!=0)
                    {
                        printf("%d step(s) before a loop of %d step(s)\n",t[x][y]-1,t[x][y-1]-t[x][y]+1);
                        break;
                    }    
                    t[x][y]=t[x][y-1]+1;
                }    
                else if(map[x][y]=='N')
                {
                    x--;
                    if(x<0) 
                    {
                        printf("%d step(s) to exit\n",t[x+1][y]);
                        break;
                    }   
                    if(t[x][y]!=0)
                    {
                        printf("%d step(s) before a loop of %d step(s)\n",t[x][y]-1,t[x+1][y]-t[x][y]+1);
                        break;
                    }    
                    t[x][y]=t[x+1][y]+1;
                }    
                else
                {
                    x++;
                    if(x>=n)
                    {
                        printf("%d step(s) to exit\n",t[x-1][y]);
                        break;
                    }    
                    if(t[x][y]!=0)
                    {
                        printf("%d step(s) before a loop of %d step(s)\n",t[x][y]-1,t[x-1][y]-t[x][y]+1);
                        break;
                    }    
                    t[x][y]=t[x-1][y]+1;
                }    
            }    
        }    
        return 0;
    }    
  • 相关阅读:
    验证一下spark Row getAS类型以及控制问题
    Spark异常处理有时间好好拜读一下,spark拍错好文章
    Hive SQL 报错
    Objenesis类库学习一下,没有符合的构造器也可以创建对象
    Scala可变参数方法或者函数传参问题
    大数据相关英文博客,感觉还不错。Mark一下http://dwgeek.com/
    Tomcat 7 'javax.el.ELException' 的解决方式(failed to parse the expression [${xxx}])
    The absolute uri: http://java.sun.com/jsp/jstl/core cannot be resolved in either web.xml or the jar
    在Tomcat中进行数据池连接是所需的包
    EL表达式
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2532777.html
Copyright © 2011-2022 走看看