zoukankan      html  css  js  c++  java
  • HDU 1038 Biker's Trip Odometer(简单的水题)

    Biker's Trip Odometer

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2098    Accepted Submission(s): 1410


    Problem Description
    Most bicycle speedometers work by using a Hall Effect sensor fastened to the front fork of the bicycle. A magnet is attached to one of the spokes on the front wheel so that it will line up with the Hall Effect switch once per revolution of the wheel. The speedometer monitors the sensor to count wheel revolutions. If the diameter of the wheel is known, the distance traveled can be easily be calculated if you know how many revolutions the wheel has made. In addition, if the time it takes to complete the revolutions is known, the average speed can also be calculated.
    For this problem, you will write a program to determine the total distance traveled (in miles) and the average speed (in Miles Per Hour) given the wheel diameter, the number of revolutions and the total time of the trip. You can assume that the front wheel never leaves the ground, and there is no slipping or skidding.
     
    Input
    Input consists of multiple datasets, one per line, of the form:

    diameter revolutions time

    The diameter is expressed in inches as a floating point value. The revolutions is an integer value. The time is expressed in seconds as a floating point value. Input ends when the value of revolutions is 0 (zero).
     
    Output
    For each data set, print:

    Trip #N: distance MPH

    Of course N should be replaced by the data set number, distance by the total distance in miles (accurate to 2 decimal places) and MPH by the speed in miles per hour (accurate to 2 decimal places). Your program should not generate any output for the ending case when revolutions is 0.

    Constants

    For p use the value: 3.1415927.
    There are 5280 feet in a mile.
    There are 12 inches in a foot.
    There are 60 minutes in an hour.
    There are 60 seconds in a minute.
    There are 201.168 meters in a furlong.
     
    Sample Input
    26 1000 5 27.25 873234 3000 26 0 1000
     
    Sample Output
    Trip #1: 1.29 928.20 Trip #2: 1179.86 1415.84
     
    Source
     
     
    很简单,给定轮子的直径,和转过的圈数,以及时间。
    求路程和速度。
    注意单位换算。
     
     
     
    #include<stdio.h>
    #include<math.h>
    const double PI=acos(-1.0);
    int main()
    {
        double d;
        int r;
        double t;
        int iCase=0;
        while(scanf("%lf%d%lf",&d,&r,&t),r)
        {
            iCase++;
            double res1=PI*d*r/(12*5280);
            double res2=res1/t*3600;
            printf("Trip #%d: %.2lf %.2lf\n",iCase,res1,res2);
        }    
        return 0;
    }    
  • 相关阅读:
    零基础入门学习Python(11)--列表:一个打了激素的数组(2)
    零基础入门学习Python(10)--列表:一个打了激素的数组
    零基础入门学习Python(9)--了不起的分支和循环3
    零基础入门学习Python(8)--了不起的分支和循环2
    零基础入门学习Python(7)--了不起的分支和循环1
    标量子查询中有ROWNUM=1怎么改?
    零基础入门学习Python(6)--Python之常用操作符
    一次ORA-01555问题分析,及SQL优化。
    零基础入门学习Python(5)--闲聊之Python的数据类型
    Python内置函数(60)——compile
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2533462.html
Copyright © 2011-2022 走看看