zoukankan      html  css  js  c++  java
  • POJ 3461 Oulipo(KMP统计子串出现次数)

    Oulipo
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 12818   Accepted: 5128

    Description

    The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

    Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

    Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

    So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

    Input

    The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

    • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
    • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

    Output

    For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

    Sample Input

    3
    BAPC
    BAPC
    AZA
    AZAZAZA
    VERDI
    AVERDXIVYERDIAN

    Sample Output

    1
    3
    0

    Source

     
     
     
     
    典型的KMP
     
    统计模式串在主串中出现的次数
     
    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    using namespace std;
    char W[10010],T[1000010];
    int wlen,tlen;
    int next[10010];
    void getNext()
    {
        int j,k;
        j=0;
        k=-1;
        next[0]=-1;
        while(j<wlen)
        {
            if(k==-1||W[j]==W[k])
            {
                next[++j]=++k;
            }
            else k=next[k];
        }
    }
    int KMP_count()
    {
        int ans=0;
        int i,j=0;
        if(wlen==1&&tlen==1)
        {
            if(W[0]==T[0])return 1;
            else return 0;
        }
        getNext();
        for(i=0;i<tlen;i++)
        {
            while(j>0&&T[i]!=W[j])
              j=next[j];
            if(W[j]==T[i])j++;
            if(j==wlen)
            {
                ans++;
                j=next[j];
            }
        }
        return ans;
    }
    int main()
    {
      //  freopen("in.txt","r",stdin);
       // freopen("out.txt","w",stdout);
        int tcase;
        scanf("%d",&tcase);
        while(tcase--)
        {
            scanf("%s%s",&W,&T);
            wlen=strlen(W);
            tlen=strlen(T);
    
            printf("%d\n",KMP_count());
        }
        return 0;
    }
  • 相关阅读:
    SQL中的选择判断
    Rsync
    LAMP性能优化的一些建议
    Toad9.7与Oracle11g在X86的Win7下的情况
    IIS中IUSR_和IWAM_:计算机名帐户的用户名和密码的用途
    winform编程中的跨线程访问资源(转)
    MSTDC服务的应用及相关错误的解决方案(转载)
    SQL Server 错误代码详解
    poj 1777梅森素数
    hdu 2815 baby_step c可为非素数
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2625755.html
Copyright © 2011-2022 走看看