zoukankan      html  css  js  c++  java
  • HDU 1711 Number Sequence (KMP找子串第一次出现的位置)

    Number Sequence

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 5898    Accepted Submission(s): 2652


    Problem Description
    Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
     
    Input
    The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
     
    Output
    For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
     
    Sample Input
    2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
     
    Sample Output
    6 -1
     
    Source
     
    Recommend
    lcy
     
     
     
    #include<stdio.h>
    int a[1000010],b[10010];
    int next[10010];
    int n,m;
    void getNext()
    {
        int j,k;
        j=0;
        k=-1;
        next[0]=-1;
        while(j<m)
        {
            if(k==-1||b[j]==b[k])
              next[++j]=++k;
            else k=next[k];
        }    
    }  
    //返回首次出现的位置 
    int KMP_Index()
    {
        int i=0,j=0;
        getNext();
        
        while(i<n && j<m)
        {
            if(j==-1||a[i]==b[j])
            {
                i++;
                j++;
            }    
            else j=next[j];
            
        }    
        if(j==m) return i-m+1;
        else return -1;
    }      
    int main()
    {
        int T;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d",&n,&m);
            for(int i=0;i<n;i++)
              scanf("%d",&a[i]);
            for(int i=0;i<m;i++)
              scanf("%d",&b[i]);
            printf("%d\n",KMP_Index());
        }    
        return 0;
    }    
    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    const int MAXN=1000010;
    
    int a[MAXN];
    int b[MAXN];
    
    int n,m;
    int next[MAXN];
    /*
    根据定义next[0]=-1,假设next[j]=k, 即P[0...k-1]==P[j-k,j-1]
    1)若P[j]==P[k],则有P[0..k]==P[j-k+1,j],很显然,next[j+1]=next[j]+1=k+1;
    2)若P[j]!=P[k],则可以把其看做模式匹配的问题,即匹配失败的时候,k值如何移动,显然k=next[k]。
    */
    
    void getNext()
    {
        int j,k;
        next[0]=-1;
        j=0;
        k=-1;
        while(j<m)
        {
            if(k==-1||b[j]==b[k])
            {
                j++;
                k++;
                next[j]=k;
            }
            else k=next[k];
        }
    }
    
    int KMP_Index()
    {
        int i=0,j=0;
        getNext();
        while(i<n&&j<m)
        {
            if(j==-1||a[i]==b[j])
            {
                i++;j++;
            }
            else j=next[j];
        }
        if(j==m)return i-m+1;
        else return -1;
    }
    int main()
    {
        int T;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d",&n,&m);
            for(int i=0;i<n;i++)scanf("%d",&a[i]);
            for(int i=0;i<m;i++)scanf("%d",&b[i]);
            printf("%d\n",KMP_Index());
        }
        return 0;
    }
  • 相关阅读:
    SQL命令
    MySQL、Oracle、SQL Server
    函数调用
    php 读取图片显示在页面上 demo
    浅谈PHP正则表达式中修饰符/i, /is, /s, /isU
    jquery $.ajax()方法
    HTML 字符实体
    php 内置支持的标签和属性
    java-03 变量与运算符
    java-02 JDK安装与环境变量配置&安装编程IDE
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2625756.html
Copyright © 2011-2022 走看看