zoukankan      html  css  js  c++  java
  • POJ 1573 Robot Motion(水模拟)

    Robot Motion
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 7892   Accepted: 3812

    Description


    A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

    N north (up the page)
    S south (down the page)
    E east (to the right on the page)
    W west (to the left on the page)

    For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

    Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

    You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

    Input

    There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

    Output

    For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

    Sample Input

    3 6 5
    NEESWE
    WWWESS
    SNWWWW
    4 5 1
    SESWE
    EESNW
    NWEEN
    EWSEN
    0 0 0

    Sample Output

    10 step(s) to exit
    3 step(s) before a loop of 8 step(s)
    

    Source

     
    不需要解释。。
    很水的模拟。。
     
     
     
    #include<stdio.h>
    #include<string.h>
    const int MAXN=20;
    char map[MAXN][MAXN];
    int a[MAXN][MAXN];
    int N,M;
    void solve(int s)
    {
        memset(a,0,sizeof(a));
        a[0][s-1]=1;
        int x=0;
        int y=s-1;
        while(1)
        {
            int tx=x,ty=y;
            if(map[x][y]=='N')tx--;
            else if(map[x][y]=='S')tx++;
            else if(map[x][y]=='W')ty--;
            else if(map[x][y]=='E')ty++;
    
            if(tx<0||tx>=N||ty<0||ty>=M)
            {
                printf("%d step(s) to exit\n",a[x][y]);
                return;
            }
            else if(a[tx][ty]!=0)
            {
                printf("%d step(s) before a loop of %d step(s)\n",a[tx][ty]-1,a[x][y]-a[tx][ty]+1);
                return;
            }
            else
            {
                a[tx][ty]=a[x][y]+1;
                x=tx;
                y=ty;
            }
        }
    }
    int main()
    {
      //  freopen("in.txt","r",stdin);
     //   freopen("out.txt","w",stdout);
        int s;
        while(scanf("%d%d%d",&N,&M,&s)!=EOF)
        {
            if(N==0&&M==0&&s==0)break;
            for(int i=0;i<N;i++)
              scanf("%s",&map[i]);
            solve(s);
        }
        return 0;
    }
  • 相关阅读:
    demo 集合
    iOS12、iOS11、iOS10、iOS9常见适配
    gem install cocoapods ERROR: While executing gem ... (Gem::FilePermissionError)
    ios LaunchScreen.storyboard 适配启动图
    加载资源文件读取以及转换成字符串的方法
    [UIApplication sharedApplication].keyWindow和[[UIApplication sharedApplication].delegate window]区别
    婚庆手机APP
    从一部电视剧开始
    论一次使用代理模式实现共用导出报表的功能
    MySql中使用EXPLAIN查看sql的执行计划
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2636330.html
Copyright © 2011-2022 走看看