zoukankan      html  css  js  c++  java
  • POJ 1274 The Perfect Stall(二分图匹配)

    The Perfect Stall
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 14447   Accepted: 6612

    Description

    Farmer John completed his new barn just last week, complete with all the latest milking technology. Unfortunately, due to engineering problems, all the stalls in the new barn are different. For the first week, Farmer John randomly assigned cows to stalls, but it quickly became clear that any given cow was only willing to produce milk in certain stalls. For the last week, Farmer John has been collecting data on which cows are willing to produce milk in which stalls. A stall may be only assigned to one cow, and, of course, a cow may be only assigned to one stall.
    Given the preferences of the cows, compute the maximum number of milk-producing assignments of cows to stalls that is possible.

    Input

    The input includes several cases. For each case, the first line contains two integers, N (0 <= N <= 200) and M (0 <= M <= 200). N is the number of cows that Farmer John has and M is the number of stalls in the new barn. Each of the following N lines corresponds to a single cow. The first integer (Si) on the line is the number of stalls that the cow is willing to produce milk in (0 <= Si <= M). The subsequent Si integers on that line are the stalls in which that cow is willing to produce milk. The stall numbers will be integers in the range (1..M), and no stall will be listed twice for a given cow.

    Output

    For each case, output a single line with a single integer, the maximum number of milk-producing stall assignments that can be made.

    Sample Input

    5 5
    2 2 5
    3 2 3 4
    2 1 5
    3 1 2 5
    1 2 
    

    Sample Output

    4

    Source

     
     
     
     
    二分图匹配。。
    套模板
     
    /*
    poj 1274
    */
    
    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    
    
    /* **************************************************************************
    //二分图匹配(匈牙利算法的DFS实现)
    //初始化:g[][]两边顶点的划分情况
    //建立g[i][j]表示i->j的有向边就可以了,是左边向右边的匹配
    //g没有边相连则初始化为0
    //uN是匹配左边的顶点数,vN是匹配右边的顶点数
    //调用:res=hungary();输出最大匹配数
    //优点:适用于稠密图,DFS找增广路,实现简洁易于理解
    //时间复杂度:O(VE)
    //***************************************************************************/
    //顶点编号从0开始的
    const int MAXN=220;
    int uN,vN;//u,v数目
    int g[MAXN][MAXN];
    int linker[MAXN];
    bool used[MAXN];
    bool dfs(int u)//从左边开始找增广路径
    {
        int v;
        for(v=0;v<vN;v++)//这个顶点编号从0开始,若要从1开始需要修改
          if(g[u][v]&&!used[v])
          {
              used[v]=true;
              if(linker[v]==-1||dfs(linker[v]))
              {//找增广路,反向
                  linker[v]=u;
                  return true;
              }
          }
        return false;//这个不要忘了,经常忘记这句
    }
    int hungary()
    {
        int res=0;
        int u;
        memset(linker,-1,sizeof(linker));
        for(u=0;u<uN;u++)
        {
            memset(used,0,sizeof(used));
            if(dfs(u)) res++;
        }
        return res;
    }
    //******************************************************************************/
    
    
    
    int main()
    {
         int v;
         int k;
         while(scanf("%d%d",&uN,&vN)!=EOF)
         {
             memset(g,0,sizeof(g));
             for(int i=0;i<uN;i++)
             {
                 scanf("%d",&k);
                 while(k--)
                 {
                     scanf("%d",&v);
                     v--;//转成下标0开始的,这个不要忘记
                     g[i][v]=1;
                 }
             }
             printf("%d\n",hungary());
         }
         return 0;
    }
  • 相关阅读:
    基于Furion的.NET5 WebApi开发框架
    由react的todolist想到的
    react第三节-基础概念梳理
    uniapp引入字体图标与uniapp传入事件对象与自定义参数
    (react+tsx)函数式组件传参问题
    关于git正确clone指定分支
    关于‘react-app-rewried 不是内部或外部命令’的深度解析
    flex下的多行对齐与预处理器中使用nth-child选择器
    webpack(2)--webapck自身的配置
    webpack解析(1)
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2646013.html
Copyright © 2011-2022 走看看