zoukankan      html  css  js  c++  java
  • POJ 3185 The Water Bowls(高斯消元)

    The Water Bowls
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 3340   Accepted: 1298

    Description

    The cows have a line of 20 water bowls from which they drink. The bowls can be either right-side-up (properly oriented to serve refreshing cool water) or upside-down (a position which holds no water). They want all 20 water bowls to be right-side-up and thus use their wide snouts to flip bowls.

    Their snouts, though, are so wide that they flip not only one bowl but also the bowls on either side of that bowl (a total of three or -- in the case of either end bowl -- two bowls).

    Given the initial state of the bowls (1=undrinkable, 0=drinkable -- it even looks like a bowl), what is the minimum number of bowl flips necessary to turn all the bowls right-side-up?

    Input

    Line 1: A single line with 20 space-separated integers

    Output

    Line 1: The minimum number of bowl flips necessary to flip all the bowls right-side-up (i.e., to 0). For the inputs given, it will always be possible to find some combination of flips that will manipulate the bowls to 20 0's.

    Sample Input

    0 0 1 1 1 0 0 1 1 0 1 1 0 0 0 0 0 0 0 0

    Sample Output

    3

    Hint

    Explanation of the sample:

    Flip bowls 4, 9, and 11 to make them all drinkable:
    0 0 1 1 1 0 0 1 1 0 1 1 0 0 0 0 0 0 0 0 [initial state]
    0 0 0 0 0 0 0 1 1 0 1 1 0 0 0 0 0 0 0 0 [after flipping bowl 4]
    0 0 0 0 0 0 0 0 0 1 1 1 0 0 0 0 0 0 0 0 [after flipping bowl 9]
    0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 [after flipping bowl 11]

    Source

    [Submit]   [Go Back]   [Status]   [Discuss]

    Home Page   Go Back  To top

    高斯消元。。

    做了一题高斯消元。。。总结个好的模板。。其他的都是虐菜啊

    /*
    POJ 1753
    */
    #include<stdio.h>
    #include<string.h>
    #include<iostream>
    #include<algorithm>
    #include<math.h>
    using namespace std;
    const int MAXN=30;
    const int INF=0x3fffffff;
    int a[MAXN][MAXN];//增广矩阵
    int x[MAXN];
    int free_x[MAXN];
    
    // 高斯消元法解方程组(Gauss-Jordan elimination).(-2表示有浮点数解,但无整数解,
    //-1表示无解,0表示唯一解,大于0表示无穷解,并返回自由变元的个数)
    //有equ个方程,var个变元。增广矩阵行数为equ,分别为0到equ-1,列数为var+1,分别为0到var.
    int Gauss(int equ,int var)
    {
        int i,j,k;
        int max_r;// 当前这列绝对值最大的行.
        int col;//当前处理的列
        int ta,tb;
        int LCM;
        int temp;
        int free_index;
        int num=0;
        for(int i=0;i<=var;i++)
        {
            x[i]=0;
            free_x[i]=0;
        }
        //转换为阶梯阵.
        col=0; // 当前处理的列
        for(k = 0;k < equ && col < var;k++,col++)
        {// 枚举当前处理的行.
    // 找到该col列元素绝对值最大的那行与第k行交换.(为了在除法时减小误差)
            max_r=k;
            for(i=k+1;i<equ;i++)
            {
                if(abs(a[i][col])>abs(a[max_r][col])) max_r=i;
            }
            if(max_r!=k)
            {// 与第k行交换.
                for(j=k;j<var+1;j++) swap(a[k][j],a[max_r][j]);
            }
            if(a[k][col]==0)
            {// 说明该col列第k行以下全是0了,则处理当前行的下一列.
                k--;
                free_x[num++]=col;
                continue;
            }
            for(i=k+1;i<equ;i++)
            {// 枚举要删去的行.
                if(a[i][col]!=0)
                {
                  //  LCM = lcm(abs(a[i][col]),abs(a[k][col]));
                  //  ta = LCM/abs(a[i][col]);
                  //  tb = LCM/abs(a[k][col]);
                  //  if(a[i][col]*a[k][col]<0)tb=-tb;//异号的情况是相加
                    for(j=col;j<var+1;j++)
                    {
                        a[i][j] ^= a[k][j];
                    }
                }
            }
        }
    
        // 1. 无解的情况: 化简的增广阵中存在(0, 0, ..., a)这样的行(a != 0).
        for (i = k; i < equ; i++)
        { // 对于无穷解来说,如果要判断哪些是自由变元,那么初等行变换中的交换就会影响,则要记录交换.
            if (a[i][col] != 0) return -1;
        }
        int stat=1<<(var-k);//自由变元有 var-k 个
        int res=INF;
        for(i=0;i<stat;i++)//枚举所有变元
        {
            int cnt=0;
            int index=i;
            for(j=0;j<var-k;j++)
            {
                x[free_x[j]]=(index&1);
                if(x[free_x[j]]) cnt++;
                index>>=1;
            }
            for(j=k-1;j>=0;j--)
            {
                int tmp=a[j][var];
                for(int l=j+1;l<var;l++)
                  if(a[j][l]) tmp^=x[l];
                x[j]=tmp;
                if(x[j])cnt++;
            }
            if(cnt<res)res=cnt;
        }
        return res;
    }
    
    void init()
    {
        for(int i=0;i<20;i++)
        {
            for(int j=0;j<20;j++)a[i][j]=0;
            a[i][i]=1;
            if(i>0)a[i][i-1]=1;
            if(i<19)a[i][i+1]=1;
        }
    }
    
    int main()
    {
      //  freopen("in.txt","r",stdin);
      //  freopen("out.txt","w",stdout);
        while(scanf("%d",&a[0][20])!=EOF)
        {
            init();
            for(int i=1;i<20;i++)scanf("%d",&a[i][20]);
            int ans=Gauss(20,20);
            printf("%d\n",ans);
        }
        return 0;
    }
  • 相关阅读:
    【做题】agc003E
    步态识别问题简介
    win10 +Kinect V1 1414环境配置
    生物特征识别数据泄露事件
    人脸识别应用领域
    爱自然
    wxid 转微信号
    Blahut-Arimoto algorithm Matlab源码
    Theorem、Proposition、Lemma和Corollary等的解释与区别
    PokerNet-poker recognition: 扑克识别 (6)
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2666092.html
Copyright © 2011-2022 走看看