zoukankan      html  css  js  c++  java
  • POJ 3624 Charm Bracelet (01背包)

    Charm Bracelet
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 13977   Accepted: 6381

    Description

    Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

    Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

    Input

    * Line 1: Two space-separated integers: N and M
    * Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

    Output

    * Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

    Sample Input

    4 6
    1 4
    2 6
    3 12
    2 7

    Sample Output

    23

    Source

     
     
     
    简单的01背包,
    开始练习背包
     
     
    /*
    简单的01背包
    */
    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    
    const int MAXN=3500;
    int dp[13000];
    int value[MAXN];//每袋的价格
    int weight[MAXN];//每袋的重量
    
    int nValue,nKind;
    
    //0-1背包,代价为cost,获得的价值为weight
    void ZeroOnePack(int cost,int weight)
    {
        for(int i=nValue;i>=cost;i--)
          dp[i]=max(dp[i],dp[i-cost]+weight);
    }
    
    int main()
    {
        while(scanf("%d%d",&nKind,&nValue)!=EOF)
        {
            for(int i=0;i<nKind;i++)scanf("%d%d",&value[i],&weight[i]);
            memset(dp,0,sizeof(dp));
            for(int i=0;i<nKind;i++)
              ZeroOnePack(value[i],weight[i]);
            printf("%d\n",dp[nValue]);
        }
        return 0;
    }
     
  • 相关阅读:
    ubuntu怎么安装下载工具uget+aria2 for firefox
    #pragma once
    opencv3在CMakeLists.txt中的调用问题
    opencv之Mat数据类型
    windows10下笔记本电脑外接显示器设置
    ubuntu16.04下笔记本电脑扩展双屏安装过程
    【问题收录】Ubuntu14.04连接两个双显示器失败的解决方案
    获取jsapi_ticket
    微信公众号中高德地图显示路线开发
    微信公众号中高德地图显示路线
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2684076.html
Copyright © 2011-2022 走看看