zoukankan      html  css  js  c++  java
  • POJ 1276 Cash Machine(多重背包)

    Cash Machine
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 20470   Accepted: 7162

    Description

    A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

    N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

    means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

    Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

    Notes:
    @ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

    Input

    The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

    cash N n1 D1 n2 D2 ... nN DN

    where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

    Output

    For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

    Sample Input

    735 3  4 125  6 5  3 350
    633 4  500 30  6 100  1 5  0 1
    735 0
    0 3  10 100  10 50  10 10

    Sample Output

    735
    630
    0
    0

    Hint

    The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

    In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

    In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

    Source

     
     
    多重背包
    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    const int MAXN=20;
    
    int dp[100010];
    
    int value[MAXN];//每袋的价格
    
    
    
    int bag[MAXN];//袋数
    
    int nValue,nKind;
    
    //0-1背包,代价为cost,获得的价值为weight
    void ZeroOnePack(int cost,int weight)
    {
        for(int i=nValue;i>=cost;i--)
          dp[i]=max(dp[i],dp[i-cost]+weight);
    }
    
    //完全背包,代价为cost,获得的价值为weight
    void CompletePack(int cost,int weight)
    {
        for(int i=cost;i<=nValue;i++)
          dp[i]=max(dp[i],dp[i-cost]+weight);
    }
    
    //多重背包
    void MultiplePack(int cost,int weight,int amount)
    {
        if(cost*amount>=nValue) CompletePack(cost,weight);
        else
        {
            int k=1;
            while(k<amount)
            {
                ZeroOnePack(k*cost,k*weight);
                amount-=k;
                k<<=1;
            }
            ZeroOnePack(amount*cost,amount*weight);//这个不要忘记了,经常掉了
        }
    }
    
    int main()
    {
        while(scanf("%d",&nValue)!=EOF)
        {
            scanf("%d",&nKind);
            for(int i=0;i<nKind;i++)
               scanf("%d%d",&bag[i],&value[i]);
            memset(dp,0,sizeof(dp));
            for(int i=0;i<nKind;i++)
              MultiplePack(value[i],value[i],bag[i]);
            printf("%d\n",dp[nValue]);
        }
        return 0;
    }
  • 相关阅读:
    尝试用微博记录 SQL Server 2012开发者训练营笔记
    Contact Manager Web API 示例[4] 异常处理(Exception Handling)
    使用IAPIExplorer列举ASP.NET Web API
    从 WebAPI Beta 更新到WebAPI RC
    Tracing in ASP.NET Web API
    一个基于asp.net2.0空间的webproxy程序:ASProxy
    微软发布平板电脑 – Surface
    Big Data, Hadoop and StreamInsight™
    REST 入门介绍
    通过企业分布式缓存共享运行时数据
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2686629.html
Copyright © 2011-2022 走看看