zoukankan      html  css  js  c++  java
  • HDU 4289 Control 第37届ACM/ICPC 成都赛区网络赛1002题 (最大流)

    Control

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 238    Accepted Submission(s): 135


    Problem Description
      You, the head of Department of Security, recently received a top-secret information that a group of terrorists is planning to transport some WMD 1 from one city (the source) to another one (the destination). You know their date, source and destination, and they are using the highway network.
      The highway network consists of bidirectional highways, connecting two distinct city. A vehicle can only enter/exit the highway network at cities only.
      You may locate some SA (special agents) in some selected cities, so that when the terrorists enter a city under observation (that is, SA is in this city), they would be caught immediately.
      It is possible to locate SA in all cities, but since controlling a city with SA may cost your department a certain amount of money, which might vary from city to city, and your budget might not be able to bear the full cost of controlling all cities, you must identify a set of cities, that:
      * all traffic of the terrorists must pass at least one city of the set.
      * sum of cost of controlling all cities in the set is minimal.
      You may assume that it is always possible to get from source of the terrorists to their destination.
    ------------------------------------------------------------
    1 Weapon of Mass Destruction
     
    Input
      There are several test cases.
      The first line of a single test case contains two integer N and M ( 2 <= N <= 200; 1 <= M <= 20000), the number of cities and the number of highways. Cities are numbered from 1 to N.
      The second line contains two integer S,D ( 1 <= S,D <= N), the number of the source and the number of the destination.
      The following N lines contains costs. Of these lines the ith one contains exactly one integer, the cost of locating SA in the ith city to put it under observation. You may assume that the cost is positive and not exceeding 107.
      The followingM lines tells you about highway network. Each of these lines contains two integers A and B, indicating a bidirectional highway between A and B.
      Please process until EOF (End Of File).
     
    Output
      For each test case you should output exactly one line, containing one integer, the sum of cost of your selected set.
      See samples for detailed information.
     
    Sample Input
    5 6 5 3 5 2 3 4 12 1 5 5 4 2 3 2 4 4 3 2 1
     
    Sample Output
    3
     
    Source
     
    Recommend
    liuyiding
     
     
    成都赛区网络赛1002题。
    一场网络赛两题最大流,用SAP模板可以秒掉。
    //1002
    /*
    HDU 4289
    G++  62ms  1888K
    最大流
    SAP
    */
    #include<stdio.h>
    #include<iostream>
    #include<map>
    #include<set>
    #include<algorithm>
    #include<string.h>
    #include<stdlib.h>
    using namespace std;
    
    const int MAXN=5000;//点数的最大值
    const int MAXM=2500000;//边数的最大值
    const int INF=0x3f3f3f3f;
    
    struct Node
    {
        int from,to,next;
        int cap;
    }edge[MAXM];
    int tol;
    int head[MAXN];
    int dep[MAXN];
    int gap[MAXN];//gap[x]=y:说明残留网络中 dep[i]==x的个数为y
    
    int n;//点的实际个数,一定是总的点的个数,包括源点和汇点
    void init()
    {
        tol=0;
        memset(head,-1,sizeof(head));
    }
    void addedge(int u,int v,int w)
    {
        edge[tol].from=u;
        edge[tol].to=v;
        edge[tol].cap=w;
        edge[tol].next=head[u];
        head[u]=tol++;
        edge[tol].from=v;
        edge[tol].to=u;
        edge[tol].cap=0;
        edge[tol].next=head[v];
        head[v]=tol++;
    }
    void BFS(int start,int end)
    {
        memset(dep,-1,sizeof(dep));
        memset(gap,0,sizeof(gap));
        gap[0]=1;
        int que[MAXN];
        int front,rear;
        front=rear=0;
        dep[end]=0;
        que[rear++]=end;
        while(front!=rear)
        {
            int u=que[front++];
            if(front==MAXN)front=0;
            for(int i=head[u];i!=-1;i=edge[i].next)
            {
                int v=edge[i].to;
                if(edge[i].cap!=0||dep[v]!=-1)continue;
                que[rear++]=v;
                if(rear==MAXN)rear=0;
                dep[v]=dep[u]+1;
                ++gap[dep[v]];
            }
        }
    }
    int SAP(int start,int end)
    {
        int res=0;
        BFS(start,end);
        int cur[MAXN];
        int S[MAXN];
        int top=0;
        memcpy(cur,head,sizeof(head));
        int u=start;
        int i;
        while(dep[start]<n)
        {
            if(u==end)
            {
                int temp=INF;
                int inser;
                for(i=0;i<top;i++)
                   if(temp>edge[S[i]].cap)
                   {
                       temp=edge[S[i]].cap;
                       inser=i;
                   }
                for(i=0;i<top;i++)
                {
                    edge[S[i]].cap-=temp;
                    edge[S[i]^1].cap+=temp;
                }
                res+=temp;
                top=inser;
                u=edge[S[top]].from;
            }
            if(u!=end&&gap[dep[u]-1]==0)//出现断层,无增广路
              break;
            for(i=cur[u];i!=-1;i=edge[i].next)
               if(edge[i].cap!=0&&dep[u]==dep[edge[i].to]+1)
                 break;
            if(i!=-1)
            {
                cur[u]=i;
                S[top++]=i;
                u=edge[i].to;
            }
            else
            {
                int min=n;
                for(i=head[u];i!=-1;i=edge[i].next)
                {
                    if(edge[i].cap==0)continue;
                    if(min>dep[edge[i].to])
                    {
                        min=dep[edge[i].to];
                        cur[u]=i;
                    }
                }
                --gap[dep[u]];
                dep[u]=min+1;
                ++gap[dep[u]];
                if(u!=start)
                  u=edge[S[--top]].from;
            }
    
        }
        return res;
    }
    
    int main()
    {
        //freopen("B.in","r",stdin);
        //freopen("B.out","w",stdout);
        int N,M;
        int u,v;
        int start;
        int end;
        while(scanf("%d%d",&N,&M)!=EOF)
        {
            init();
            scanf("%d%d",&start,&end);
            start=2*start-1;
            end=2*end;
            n=2*N;
            for(int i=1;i<=N;i++)
            {
                scanf("%d",&u);
                addedge(2*i-1,2*i,u);
                addedge(2*i,2*i-1,u);
            }
            while(M--)
            {
                scanf("%d%d",&u,&v);
                addedge(2*u,2*v-1,INF);
                addedge(2*v,2*u-1,INF);//这里一定要注意
            }
            printf("%d\n",SAP(start,end));
        }
        return 0;
    }
  • 相关阅读:
    Spring 整合Mybatis
    Spring 配置说明
    AutoCAD.Net/C#.Net QQ群:193522571 虚拟方法的使用
    VLAN帧格式详解
    内网安全体系建设工作思路
    IT公司常见的内网漏洞表格
    内网安全运营的逻辑体系架构
    域安全的基础知识
    利用DNS日志进行MySQL盲注
    Linux内存凭据提取mimipenguin
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2688550.html
Copyright © 2011-2022 走看看