zoukankan      html  css  js  c++  java
  • HDU 4405 Aeroplane chess 第37届ACM/ICPC 金华赛区网络赛(递推求期望)

    Aeroplane chess

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 229    Accepted Submission(s): 158


    Problem Description
    Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

    There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

    Please help Hzz calculate the expected dice throwing times to finish the game.
     
    Input
    There are multiple test cases.
    Each test case contains several lines.
    The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
    Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
    The input end with N=0, M=0.
     
    Output
    For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
     
    Sample Input
    2 0 8 3 2 4 4 5 7 8 0 0
     
    Sample Output
    1.1667 2.3441
     
    Source
     
    Recommend
    zhoujiaqi2010
     
     
    很常规的求数学期望。
    从后望前递推。
    //1006
    #include<stdio.h>
    #include<iostream>
    #include<map>
    #include<set>
    #include<algorithm>
    #include<string.h>
    #include<stdlib.h>
    using namespace std;
    const int MAXN=100020;
    
    struct Node
    {
        int from,to;
        int next;
    }edge[MAXN];
    int head[MAXN];
    int tol;
    void add(int u,int v)
    {
        edge[tol].from=u;
        edge[tol].to=v;
        edge[tol].next=head[u];
        head[u]=tol++;
    }
    
    double  dp[MAXN];
    bool vis[MAXN];
    int main()
    {
        //freopen("F.in","r",stdin);
       // freopen("F.out","w",stdout);
        int n,m;
        int u,v;
        while(scanf("%d%d",&n,&m)!=EOF)
        {
            if(n==0&&m==0)break;
            memset(dp,0,sizeof(dp));
            memset(head,-1,sizeof(head));
            memset(vis,false,sizeof(vis));
            tol=0;
            while(m--)
            {
                scanf("%d%d",&u,&v);
                add(v,u);
            }
            dp[n]=-1;
            //printf("%d  %.4lf\n",n,dp[n]);
            for(int i=n;i>=0;i--)
            {
                if(!vis[i])
                {
                    dp[i]+=1;
                    for(int j=i+1;j<=i+6;j++)
                      dp[i]+=(dp[j]/6.0);
                    vis[i]=true;
                }
                for(int j=head[i];j!=-1;j=edge[j].next)
                {
                    int v=edge[j].to;
                    dp[v]=dp[i];
                    vis[v]=true;
                }
              //  printf("%d  %.4lf\n",i,dp[i]);
            }
            printf("%.4lf\n",dp[0]);
    
        }
        return 0;
    }
  • 相关阅读:
    【西瓜书】周志华《机器学习》学习笔记与习题探讨(一)
    01-线性回归算法
    NumPy 字符串函数
    Numpy函数分类
    Excel一对多查询(index+small+if)
    支付机构MRC模
    数据分析方法论
    窗口函数/解析函数
    数据分析
    底层逻辑
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2698535.html
Copyright © 2011-2022 走看看