zoukankan      html  css  js  c++  java
  • ZOJ 3659 Conquer a New Region 第37届ACM/ICPC 长春赛区现场赛E题 (并查集)

    Conquer a New Region

    Time Limit: 5 Seconds      Memory Limit: 32768 KB

    The wheel of the history rolling forward, our king conquered a new region in a distant continent.

    There are N towns (numbered from 1 to N) in this region connected by several roads. It's confirmed that there is exact one route between any two towns. Traffic is important while controlled colonies are far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to transport at most C(i, j) goods between town i and town j if there is a road between them. And for a route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and j which is equal to the minimum capacity of the roads on the route.

    Our king wants to select a center town to restore his war-resources in which the total traffic capacities from the center to the other N - 1 towns is maximized. Now, you, the best programmer in the kingdom, should help our king to select this center.

    Input

    There are multiple test cases.

    The first line of each case contains an integer N. (1 ≤ N ≤ 200,000)

    The next N - 1 lines each contains three integers a, b, c indicating there is a road between town a and town b whose capacity is c. (1 ≤ a, b ≤ N, 1 ≤ c ≤ 100,000)

    Output

    For each test case, output an integer indicating the total traffic capacity of the chosen center town.

    Sample Input

    4
    1 2 2
    2 4 1
    2 3 1
    4
    1 2 1
    2 4 1
    2 3 1
    

    Sample Output

    4
    3
    

    Contest: The 2012 ACM-ICPC Asia Changchun Regional Contest

    本题在长春时没有做出来,一直往树形DP方面想。也想过用边从小到大把规模逐渐缩小,但是很难实现。

    其实应该用并查集,把边从大到小地加入,合并。注意合并的时候是有方向的。要看合并到那边得到的值更大。

    杯具啊,这样的题目那个时候竟然没有想出来~~~~

    #include<stdio.h>
    #include<iostream>
    #include<string.h>
    #include<algorithm>
    using namespace std;
    const int MAXN=200010;
    
    struct Node
    {
        int num;
        long long sum;
    }node[MAXN];
    
    int F[MAXN];
    
    int find(int x)
    {
        if(F[x]==-1)return x;
        return F[x]=find(F[x]);
    }
    
    struct Edge
    {
        int a,b,c;
    }edge[MAXN];
    
    bool cmp(Edge a,Edge b)
    {
        return a.c>b.c;
    }
    int main()
    {
        int n;
        while(scanf("%d",&n)!=EOF)
        {
            for(int i=0;i<n-1;i++)
              scanf("%d%d%d",&edge[i].a,&edge[i].b,&edge[i].c);
            sort(edge,edge+n-1,cmp);
    
            for(int i=1;i<=n;i++)
            {
                node[i].num=1;
                node[i].sum=0;
                F[i]=-1;
            }
    
            for(int i=0;i<n-1;i++)
            {
                int a=edge[i].a;
                int b=edge[i].b;
                int t1=find(a);
                int t2=find(b);
                if(node[t1].sum+(long long)edge[i].c*node[t2].num<node[t2].sum+(long long)edge[i].c*node[t1].num)
                {
                    F[t1]=t2;
                    node[t2].num+=node[t1].num;
                    node[t2].sum+=(long long)edge[i].c*node[t1].num;
                }
                else
                {
                    F[t2]=t1;
                    node[t1].num+=node[t2].num;
                    node[t1].sum+=(long long)edge[i].c*node[t2].num;
                }
            }
            printf("%lld\n",node[find(1)].sum);
    
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    冒泡排序及优化
    Map的三种遍历
    抽象类以及接口的异同
    安卓仿制新浪微博(一)之OAuth2授权接口
    安卓handler.post问题
    Git——版本控制器概述
    Linux概述及简单命令
    JBoss7配置-支持IPv4和IPv6双栈环境
    作用域public,private,protected,以及不写时的区别
    UML类图画法及类之间几种关系
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2727106.html
Copyright © 2011-2022 走看看