zoukankan      html  css  js  c++  java
  • HDU 1073 Online Judge (字符串处理,简单题)

    Online Judge

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3389    Accepted Submission(s): 1276


    Problem Description
    Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user's result file, then the system compare the two files. If the two files are absolutly same, then the Judge System return "Accepted", else if the only differences between the two files are spaces(' '), tabs('\t'), or enters('\n'), the Judge System should return "Presentation Error", else the system will return "Wrong Answer".

    Given the data of correct output file and the data of user's result file, your task is to determine which result the Judge System will return.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case has two parts, the data of correct output file and the data of the user's result file. Both of them are starts with a single line contains a string "START" and end with a single line contains a string "END", these two strings are not the data. In other words, the data is between the two strings. The data will at most 5000 characters.
     
    Output
    For each test cases, you should output the the result Judge System should return.
     
    Sample Input
    4 START 1 + 2 = 3 END START 1+2=3 END START 1 + 2 = 3 END START 1 + 2 = 3 END START 1 + 2 = 3 END START 1 + 2 = 4 END START 1 + 2 = 3 END START 1 + 2 = 3 END
     
    Sample Output
    Presentation Error Presentation Error Wrong Answer Presentation Error
     
    Author
    Ignatius.L
     
     
     
    简单的题目。
    主要是加了字符'\n'
    每行的结束我都加上了'\n'字符。
    之后比较就可以了。
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    #include<iostream>
    #include<math.h>
    using namespace std;
    const int MAXN=5050;
    
    char a1[MAXN],a2[MAXN];
    char b1[MAXN],b2[MAXN];
    char temp[MAXN];
    void input(char a[],char b[])
    {
        gets(temp);
        while(strcmp(temp,"START")!=0)gets(temp);
    
        while(gets(temp))
        {
            if(strcmp(temp,"END")==0)break;
            if(strlen(temp)!=0)strcat(a,temp);
            strcat(a,"\n");
        }
        int t=0;
        int len=strlen(a);
        for(int i=0;i<len;i++)
        {
            if(a[i]!=' '&&a[i]!='\t'&&a[i]!='\n')
              b[t++]=a[i];
        }
        b[t]='\0';
    }
    
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
        int T;
        scanf("%d",&T);
        while(T--)
        {
            a1[0]='\0';
            a2[0]='\0';
            input(a1,b1);
            input(a2,b2);
            if(strcmp(a1,a2)==0)printf("Accepted\n");
            else if(strcmp(b1,b2)==0)printf("Presentation Error\n");
            else printf("Wrong Answer\n");
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    获取SqlServer2005表结构
    SQL SERVER 2005连接其它数据库并导入数据表
    vs2008安装失败问题
    Elmah使用方法
    使用postman发送请求,body为空
    docker的简单使用
    mongodb5最新版本的安装和向外暴露端口
    初探gin框架
    img图片的src指定为网络中随便找的图片链接,但是控制台报错get请求403
    父元素为flex布局时,设置最后一个子元素靠右,其他靠左
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2743788.html
Copyright © 2011-2022 走看看