zoukankan      html  css  js  c++  java
  • POJ 1703 Find them, Catch them (并查集)

    Find them, Catch them
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 23816   Accepted: 7130

    Description

    The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

    Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

    1. D [a] [b] 
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

    2. A [a] [b] 
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

    Input

    The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

    Output

    For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

    Sample Input

    1
    5 5
    A 1 2
    D 1 2
    A 1 2
    D 2 4
    A 1 4
    

    Sample Output

    Not sure yet.
    In different gangs.
    In the same gang.
    

    Source

     
     
     
     


    并查集的应用,用于判断种类,对2取模就可以了。

    #include <stdio.h>
    #include <algorithm>
    #include <iostream>
    #include <string.h>
    using namespace std;
    
    const int MAXN=100010;
    int F[MAXN];
    int val[MAXN];
    int find(int x)
    {
        if(F[x]==-1)return x;
        int tmp=find(F[x]);
        val[x]=(val[x]+val[F[x]])%2;
        return F[x]=tmp;
    }
    void bing(int x,int y)
    {
        int t1=find(x);
        int t2=find(y);
        if(t1!=t2)
        {
            F[t1]=t2;
            val[t1]=(val[y]-val[x]+1)%2;
        }
    }
    int main()
    {
        int T;
        char str[10];
        int u,v;
        int n,m;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d%d",&n,&m);
            memset(F,-1,sizeof(F));
            memset(val,0,sizeof(val));
            while(m--)
            {
                scanf("%s%d%d",&str,&u,&v);
                if(str[0]=='A')
                {
                    if(find(u)!=find(v))
                    {//题目说两个集团至少有一个人,所以N==2的时候单独考虑,但是不考虑这个也可以AC,估计没有这样的数据
                        if(n==2)printf("In different ganges.\n");
                        else printf("Not sure yet.\n");
                    }
                    else
                    {
                        if(val[u]!=val[v])printf("In different gangs.\n");
                        else printf("In the same gang.\n");
                    }
                }
                else
                {
                    bing(u,v);
                }
            }
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    pch文件配置出现 Expected unqualified-id 和 Unkown type name 'NSString'
    App Store Connect Operation Error ERROR ITMS-90032: "Invalid Image Path
    Xcode面板的使用
    KVO的使用
    苹果开发者账号注册-您在注册时提供的地址无效或者不完整
    Apple导出p12证书 导出证书为p12 Apple开发
    iOS开发-导出profile文件
    App Store提交审核报错 ERROR ITMS-90087解决办法
    Win10 的操作中心如果不见了
    什么时候调用dealloc
  • 原文地址:https://www.cnblogs.com/kuangbin/p/2996732.html
Copyright © 2011-2022 走看看