zoukankan      html  css  js  c++  java
  • POJ 1984 Navigation Nightmare (并查集)

    Navigation Nightmare
    Time Limit: 2000MS   Memory Limit: 30000K
    Total Submissions: 3167   Accepted: 1317
    Case Time Limit: 1000MS

    Description

    Farmer John's pastoral neighborhood has N farms (2 <= N <= 40,000), usually numbered/labeled 1..N. A series of M (1 <= M < 40,000) vertical and horizontal roads each of varying lengths (1 <= length <= 1000) connect the farms. A map of these farms might look something like the illustration below in which farms are labeled F1..F7 for clarity and lengths between connected farms are shown as (n): 
               F1 --- (13) ---- F6 --- (9) ----- F3
    
    | |
    (3) |
    | (7)
    F4 --- (20) -------- F2 |
    | |
    (2) F5
    |
    F7

    Being an ASCII diagram, it is not precisely to scale, of course. 

    Each farm can connect directly to at most four other farms via roads that lead exactly north, south, east, and/or west. Moreover, farms are only located at the endpoints of roads, and some farm can be found at every endpoint of every road. No two roads cross, and precisely one path 
    (sequence of roads) links every pair of farms. 

    FJ lost his paper copy of the farm map and he wants to reconstruct it from backup information on his computer. This data contains lines like the following, one for every road: 

    There is a road of length 10 running north from Farm #23 to Farm #17 
    There is a road of length 7 running east from Farm #1 to Farm #17 
    ... 

    As FJ is retrieving this data, he is occasionally interrupted by questions such as the following that he receives from his navigationally-challenged neighbor, farmer Bob: 

    What is the Manhattan distance between farms #1 and #23? 

    FJ answers Bob, when he can (sometimes he doesn't yet have enough data yet). In the example above, the answer would be 17, since Bob wants to know the "Manhattan" distance between the pair of farms. 
    The Manhattan distance between two points (x1,y1) and (x2,y2) is just |x1-x2| + |y1-y2| (which is the distance a taxicab in a large city must travel over city streets in a perfect grid to connect two x,y points). 

    When Bob asks about a particular pair of farms, FJ might not yet have enough information to deduce the distance between them; in this case, FJ apologizes profusely and replies with "-1". 

    Input

    * Line 1: Two space-separated integers: N and M
    

    * Lines 2..M+1: Each line contains four space-separated entities, F1,
    F2, L, and D that describe a road. F1 and F2 are numbers of
    two farms connected by a road, L is its length, and D is a
    character that is either 'N', 'E', 'S', or 'W' giving the
    direction of the road from F1 to F2.

    * Line M+2: A single integer, K (1 <= K <= 10,000), the number of FB's
    queries

    * Lines M+3..M+K+2: Each line corresponds to a query from Farmer Bob
    and contains three space-separated integers: F1, F2, and I. F1
    and F2 are numbers of the two farms in the query and I is the
    index (1 <= I <= M) in the data after which Bob asks the
    query. Data index 1 is on line 2 of the input data, and so on.

    Output

    * Lines 1..K: One integer per line, the response to each of Bob's
    
    queries. Each line should contain either a distance
    measurement or -1, if it is impossible to determine the
    appropriate distance.

    Sample Input

    7 6
    1 6 13 E
    6 3 9 E
    3 5 7 S
    4 1 3 N
    2 4 20 W
    4 7 2 S
    3
    1 6 1
    1 4 3
    2 6 6
    

    Sample Output

    13
    -1
    10
    

    Hint

    At time 1, FJ knows the distance between 1 and 6 is 13. 
    At time 3, the distance between 1 and 4 is still unknown. 
    At the end, location 6 is 3 units west and 7 north of 2, so the distance is 10. 

    Source

     
     
     
    并查集的应用。
    注意路径压缩。
    X和Y坐标都要变化。
     
    /*
    POJ 1984
    并查集
    */
    
    #include <stdio.h>
    #include <string.h>
    #include <iostream>
    #include <algorithm>
    #include <math.h>
    using namespace std;
    
    const int MAXN=40010;
    int F[MAXN];
    int dx[MAXN],dy[MAXN];
    
    
    int F1[MAXN],F2[MAXN],L[MAXN];
    char D[MAXN][3];
    
    struct Node
    {
        int u,v;
        int index;
        int I;
    }node[MAXN];
    int ans[MAXN];
    
    int find(int x)
    {
        if(F[x]==-1)return x;
        int tmp=find(F[x]);
        dx[x]+=dx[F[x]];
        dy[x]+=dy[F[x]];
        return F[x]=tmp;
    }
    bool cmp(Node a,Node b)
    {
        return a.I<b.I;
    }
    int main()
    {
        int n,m;
        int Q;
        while(scanf("%d%d",&n,&m)==2)
        {
            memset(F,-1,sizeof(F));
            memset(dx,0,sizeof(dx));
            memset(dy,0,sizeof(dy));
            for(int i=1;i<=m;i++)
            {
                scanf("%d%d%d%s",&F1[i],&F2[i],&L[i],&D[i]);
            }
            scanf("%d",&Q);
            for(int i=0;i<Q;i++)
            {
                scanf("%d%d%d",&node[i].u,&node[i].v,&node[i].I);
                node[i].index=i;
            }
            sort(node,node+Q,cmp);
            int t=1;
            for(int i=0;i<Q;i++)
            {
                while(t<=m&&node[i].I>=t)
                {
                    int t1=find(F1[t]),t2=find(F2[t]);
                    if(t1!=t2)
                    {
                        F[t2]=t1;
                        if(D[t][0]=='N')
                        {
                            dy[t2]=dy[F1[t]]-dy[F2[t]]+L[t];
                            dx[t2]=dx[F1[t]]-dx[F2[t]];
                        }
                        else if(D[t][0]=='S')
                        {
                            dy[t2]=dy[F1[t]]-dy[F2[t]]-L[t];
                            dx[t2]=dx[F1[t]]-dx[F2[t]];
                        }
                        else if(D[t][0]=='E')
                        {
                            dx[t2]=dx[F1[t]]-dx[F2[t]]+L[t];
                            dy[t2]=dy[F1[t]]-dy[F2[t]];
                        }
                        else if(D[t][0]=='W')
                        {
                            dx[t2]=dx[F1[t]]-dx[F2[t]]-L[t];
                            dy[t2]=dy[F1[t]]-dy[F2[t]];
                        }
                    }
                    t++;
                }
                if(find(node[i].u)!=find(node[i].v))ans[node[i].index]=-1;
                else
                {
                    ans[node[i].index]=abs(dx[node[i].u]-dx[node[i].v])+abs(dy[node[i].u]-dy[node[i].v]);
                }
            }
            for(int i=0;i<Q;i++)printf("%d\n",ans[i]);
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    mysql innodb ini
    innodb_flush_method
    mysql查询缓存
    查看表的索引
    mysql key PRI UNI MUL
    E160028
    mysql命令
    No identifier specified for entity
    在画图板中添加文本并更改文本颜色
    在Windows资源管理器中预览PowerShell文件
  • 原文地址:https://www.cnblogs.com/kuangbin/p/3000475.html
Copyright © 2011-2022 走看看