zoukankan      html  css  js  c++  java
  • POJ 2236 Wireless Network (并查集)

    Wireless Network
    Time Limit: 10000MS   Memory Limit: 65536K
    Total Submissions: 13323   Accepted: 5638

    Description

    An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

    In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

    Input

    The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
    1. "O p" (1 <= p <= N), which means repairing computer p. 
    2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

    The input will not exceed 300000 lines. 

    Output

    For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

    Sample Input

    4 1
    0 1
    0 2
    0 3
    0 4
    O 1
    O 2
    O 4
    S 1 4
    O 3
    S 1 4
    

    Sample Output

    FAIL
    SUCCESS
    

    Source

     
     
     
    #include <stdio.h>
    #include <iostream>
    #include <algorithm>
    #include <math.h>
    #include <string.h>
    using namespace std;
    const int MAXN=1010;
    const double eps=1e-6;
    int F[MAXN];
    int find(int x)
    {
        if(F[x]==-1)return x;
        return F[x]=find(F[x]);
    }
    void bing(int u,int v)
    {
        int t1=find(u),t2=find(v);
        if(t1!=t2)F[t1]=t2;
    }
    struct Node
    {
        double x,y;
    }node[MAXN];
    double dis(Node a,Node b)
    {
        return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
    }
    bool g[MAXN][MAXN];
    
    bool used[MAXN];
    
    int main()
    {
        int n,d;
        memset(g,false,sizeof(g));
        memset(used,false,sizeof(used));
        memset(F,-1,sizeof(F));
        scanf("%d%d",&n,&d);
        for(int i=1;i<=n;i++)
          scanf("%lf%lf",&node[i].x,&node[i].y);
        for(int i=1;i<=n;i++)
          for(int j=1;j<=n;j++)
           if(dis(node[i],node[j])<d+eps)
             g[i][j]=true;
        char op[10];
        int u,v;
        while(scanf("%s",&op)==1)
        {
            if(op[0]=='O')
            {
                scanf("%d",&u);
                if(!used[u])
                {
                    for(int i=1;i<=n;i++)
                      if(used[i]&&g[u][i])
                        bing(u,i);
                    used[u]=true;
                }
            }
            else
            {
                scanf("%d%d",&u,&v);
                if(find(u)==find(v))printf("SUCCESS\n");
                else printf("FAIL\n");
            }
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    Java虚拟机及运行时数据区
    Math小记
    利用BitMap进行大数据排序去重
    Java直接内存与堆内存
    【分布式搜索引擎】Elasticsearch之安装Elasticsearch可视化平台Kibana
    【分布式搜索引擎】Elasticsearch之如何安装Elasticsearch
    【微信错误】{"errcode":"40013","errmsg":"invalid appid hint: [mackRA06203114]","success":false}
    【Java】理解ClassNotFoundException与NoClassDefFoundError的区别
    【Spring Boot】Spring Boot之使用AOP实现数据库多数据源自动切换
    【异常】The dependencies of some of the beans in the application context form a cycle
  • 原文地址:https://www.cnblogs.com/kuangbin/p/3000496.html
Copyright © 2011-2022 走看看