zoukankan      html  css  js  c++  java
  • POJ 2492 A Bug's Life (并查集)

    A Bug's Life
    Time Limit: 10000MS   Memory Limit: 65536K
    Total Submissions: 23380   Accepted: 7603

    Description

    Background 
    Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
    Problem 
    Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

    Input

    The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

    Output

    The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

    Sample Input

    2
    3 3
    1 2
    2 3
    1 3
    4 2
    1 2
    3 4

    Sample Output

    Scenario #1:
    Suspicious bugs found!
    
    Scenario #2:
    No suspicious bugs found!

    Hint

    Huge input,scanf is recommended.

    Source

    TUD Programming Contest 2005, Darmstadt, Germany
     
     
     
     
     
     
    #include <stdio.h>
    #include <algorithm>
    #include <iostream>
    #include <string.h>
    using namespace std;
    const int MAXN=2010;
    int F[MAXN];
    int val[MAXN];
    int find(int x)
    {
        if(F[x]==-1)return x;
        int tmp=find(F[x]);
        val[x]+=val[F[x]];
        val[x]%=2;
        return F[x]=tmp;
    }
    int main()
    {
        int T;
        int n,m;
        scanf("%d",&T);
        int iCase=0;
        while(T--)
        {
            iCase++;
            memset(F,-1,sizeof(F));
            memset(val,0,sizeof(val));
            scanf("%d%d",&n,&m);
            bool flag=true;
            int u,v;
            while(m--)
            {
                scanf("%d%d",&u,&v);
                if(!flag)continue;
                int t1=find(u),t2=find(v);
                if(t1==t2)
                {
                    if(val[u]==val[v])flag=false;
                }
                else
                {
                    F[t1]=t2;
                    val[t1]=val[v]-val[u]+1;
                    val[t1]%=2;
                }
            }
            if(flag)printf("Scenario #%d:\nNo suspicious bugs found!\n\n",iCase);
            else printf("Scenario #%d:\nSuspicious bugs found!\n\n",iCase);
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    SQL最小 最大时间 查询
    Linq Except,Distinct,Left Join
    Js 刷新页面
    olgaInteractive Shape Modeling(0)
    olgaInteractive Shape Modeling(1):classmaterials
    olgaInteractive Shape Modeling(1):classmaterials:Shape Creation and Deformation
    olgaInteractive Shape Modeling(2):related papers
    计算机内部如何存储数据,关于源码、补码的问题!
    sprintf用法解析
    堆与栈有什么区别?
  • 原文地址:https://www.cnblogs.com/kuangbin/p/3000501.html
Copyright © 2011-2022 走看看