zoukankan      html  css  js  c++  java
  • HDU 1074 Doing Homework (状态压缩DP)

    Doing Homework

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3595    Accepted Submission(s): 1424


    Problem Description
    Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
    Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework). 

    Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
     
    Output
    For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
     
    Sample Input
    2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
     
    Sample Output
    2 Computer Math English 3 Computer English Math
    Hint
    In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.
     
    Author
    Ignatius.L
     
     
     
     
    以前做过的题目。
    复习DP又做到了
    状态压缩DP,写多了自然理解更加深入了
     
    /*
    HDU 1074
    1<=N<=15
    采用状态压缩DP
    需要输出顺序,用pre数组。
    因为一开始是按照字典序排列的,所以从小到大dp可以输出字典序最小的解
    */
    
    #include <stdio.h>
    #include <algorithm>
    #include <iostream>
    #include <string.h>
    using namespace std;
    const int MAXN=16;
    const int INF=0x3f3f3f3f;
    struct Node
    {
        char name[110];
        int D,C;
    }node[MAXN];
    int dp[1<<MAXN];
    int pre[1<<MAXN];
    int n;
    
    void output(int status)
    {
        if(status==0)return;
        int t=0;
        for(int i=0;i<n;i++)
          if( (status&(1<<i))!=0 && (pre[status]&(1<<i))==0 )
          {
              t=i;
              break;
          }
        output(pre[status]);
        printf("%s\n",node[t].name);
    }
    
    int main()
    {
        int T;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d",&n);
            for(int i=0;i<n;i++)
              scanf("%s%d%d",&node[i].name,&node[i].D,&node[i].C);
            for(int i=0;i<(1<<n);i++)
              dp[i]=INF;
            dp[0]=0;
            for(int i=0;i<(1<<n);i++)
            {
                for(int j=0;j<n;j++)
                {
                    if(i&(1<<j))continue;
                    int s=0;
                    for(int k=0;k<n;k++)
                      if(i&(1<<k))
                         s+=node[k].C;
                    s+=node[j].C;
                    if(s>node[j].D)s=s-node[j].D;
                    else s=0;
                    if(dp[i|(1<<j)]>dp[i]+s)
                    {
                        dp[i|(1<<j)]=dp[i]+s;
                        pre[i|(1<<j)]=i;
                    }
                }
            }
            printf("%d\n",dp[(1<<n)-1]);
            output((1<<n)-1);
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    作品-网站-[原生开发]云鸽信息网
    ASYNC_NETWORK_IO和PREEMPTIVE_OS_WAITFORSINGLEOBJECT等待事件
    还原一直卡在ASYNC_IO_COMPLETION浅析
    B树之C语言实现(包含查找、删除、插入)
    Asp.Net Core 禁用预编译
    ASP.NET Core Razor 视图组件
    WITH RECOMPILE 和 OPTION(RECOMPILE) 使用上的区别
    如何减少SQL Server中的PREEMPTIVE_OS_WRITEFILEGATHER等待类型
    WITH RECOMPILE和OPTION(RECOMPILE)区别
    SQL Server PageIOLatch和PageLatch
  • 原文地址:https://www.cnblogs.com/kuangbin/p/3016987.html
Copyright © 2011-2022 走看看