zoukankan      html  css  js  c++  java
  • HDU 1171 Big Event in HDU(背包)

    Big Event in HDU

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 16224    Accepted Submission(s): 5725


    Problem Description
    Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
    The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
    A test case starting with a negative integer terminates input and this test case is not to be processed.
     
    Output
    For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
     
    Sample Input
    2 10 1 20 1 3 10 1 20 2 30 1 -1
     
    Sample Output
    20 10 40 40
     
    Author
    lcy

    题目意思就是n种东西,知道价值和数量。问尽量分成两份,两份对应的价值,先输出大的,再输出小的。

    以前用母函数做的,今天做DP复习了下,貌似直接用多重背包更加简单。想想以前的母函数的题目,貌似很多时候都可以换成背包做的

    #include <stdio.h>
    #include <iostream>
    #include <algorithm>
    #include <string.h>
    #include <queue>
    #include <string>
    #include <set>
    #include <map>
    #include <vector>
    using namespace std;
    const int MAXN=250010;
    int dp[MAXN];
    
    int nValue;
    //0-1背包,代价为cost,获得的价值为weight
    void ZeroOnePack(int cost,int weight)
    {
        for(int i=nValue;i>=cost;i--)
            dp[i]=max(dp[i],dp[i-cost]+weight);
    }
    //完全背包,代价为cost,获得的价值为weight
    void CompletePack(int cost,int weight)
    {
        for(int i=cost;i<=nValue;i++)
            dp[i]=max(dp[i],dp[i-cost]+weight);
    }
    //多重背包
    void MultiplePack(int cost,int weight,int amount)
    {
        if(cost*amount>=nValue)CompletePack(cost,weight);
        else
        {
            int k=1;
            while(k<amount)
            {
                ZeroOnePack(k*cost,k*weight);
                amount-=k;
                k<<=1;
            }
            ZeroOnePack(amount*cost,amount*weight);
        }
    }
    int a[55],b[55];
    int main()
    {
        int n;
        while(scanf("%d",&n)==1)
        {
            if(n<0)break;
            nValue=0;
            for(int i=0;i<n;i++)
            {
                scanf("%d%d",&a[i],&b[i]);
                nValue+=a[i]*b[i];
            }
            memset(dp,0,sizeof(dp));
            for(int i=0;i<n;i++)
            {
                if(b[i]==1)ZeroOnePack(a[i],a[i]);
                else MultiplePack(a[i],a[i],b[i]);
            }
            int t=nValue/2;
            while(dp[t]!=t)t--;
            printf("%d %d\n",nValue-t,t);
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    微信小程序开发(十一)获取手机的完整详细信息
    24小时学通Linux内核总结篇(kconfig和Makefile & 讲不出再见)
    24小时学通Linux内核之向内核添加代码
    24小时学通Linux内核之构建Linux内核
    24小时学通Linux内核之电源开和关时都发生了什么
    24小时学通Linux内核之调度和内核同步
    24小时学通Linux内核之有关Linux文件系统实现的问题
    24小时学通Linux内核之如何处理输入输出操作
    24小时学通Linux内核之内存管理方式
    24小时学通Linux内核之进程
  • 原文地址:https://www.cnblogs.com/kuangbin/p/3022741.html
Copyright © 2011-2022 走看看