zoukankan      html  css  js  c++  java
  • POJ 3254 Corn Fields(状态压缩DP)

    Corn Fields
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 4739   Accepted: 2506

    Description

    Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

    Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

    Input

    Line 1: Two space-separated integers: M and N 
    Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

    Output

    Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

    Sample Input

    2 3
    1 1 1
    0 1 0

    Sample Output

    9

    Hint

    Number the squares as follows:
    1 2 3
      4  

    There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

    Source

     
     
     
     
    很简单的状态压缩入门题。
     
    可以先预处理可行的状态。
    然后使用滚动数组实现。
    //============================================================================
    // Name        : poj.cpp
    // Author      : 
    // Version     :
    // Copyright   : Your copyright notice
    // Description : Hello World in C++, Ansi-style
    //============================================================================
    
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    using namespace std;
    int a[15];
    int dp[2][400];
    int state[400];
    const int MOD=100000000;
    int cnt;
    void init()
    {
        cnt=0;
        for(int i=0;i<(1<<12);i++)
            if((i&(i<<1))==0  && (i&(i>>1))==0)
                state[cnt++]=i;
    }
    
    int main()
    {
    //    freopen("in.txt","r",stdin);
    //    freopen("out.txt","w",stdout);
        init();
        int n,m;
        int t;
        while(scanf("%d%d",&n,&m)==2)
        {
            for(int i=0;i<n;i++)
            {
                a[i]=0;
                for(int j=0;j<m;j++)
                {
                    a[i]<<=1;
                    scanf("%d",&t);
                    t=1-t;
                    a[i]|=t;
                }
            }
            memset(dp,0,sizeof(dp));
            int now=0;
            dp[now][0]=1;
            int tot=(1<<m);
            for(int i=0;i<n;i++)
            {
                for(int j=0;j<cnt&&state[j]<tot;j++)
                    if(dp[now][j])
                    {
                        for(int k=0;k<cnt&&state[k]<tot;k++)
                        {
                            if(state[k]&a[i])continue;
                            if(state[k]&state[j])continue;
                            dp[now^1][k]+=dp[now][j];
                            dp[now^1][k]%=MOD;
                        }
                    }
                for(int j=0;j<cnt;j++)dp[now][j]=0;
                now^=1;
            }
            int ans=0;
            for(int i=0;i<cnt&&state[i]<tot;i++)
            {
                ans+=dp[now][i];
                ans%=MOD;
            }
            printf("%d\n",ans);
        }
    
        return 0;
    }
     
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    JavaScript将数字转换为大写金额
    css浮动
    JS合并数组的几种方法及优劣比较
    jquery.zclip.js粘贴功能
    iframe获取元素
    某些框架,类库
    web前端基础知识!
    前端开发流程
    学习其他前端技术
    SVN的学习以及使用!
  • 原文地址:https://www.cnblogs.com/kuangbin/p/3044417.html
Copyright © 2011-2022 走看看