zoukankan      html  css  js  c++  java
  • HDU 3032 Nim or not Nim?(博弈,打表找规律)

    Nim or not Nim?

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 540    Accepted Submission(s): 246


    Problem Description
    Nim is a two-player mathematic game of strategy in which players take turns removing objects from distinct heaps. On each turn, a player must remove at least one object, and may remove any number of objects provided they all come from the same heap.

    Nim is usually played as a misere game, in which the player to take the last object loses. Nim can also be played as a normal play game, which means that the person who makes the last move (i.e., who takes the last object) wins. This is called normal play because most games follow this convention, even though Nim usually does not.

    Alice and Bob is tired of playing Nim under the standard rule, so they make a difference by also allowing the player to separate one of the heaps into two smaller ones. That is, each turn the player may either remove any number of objects from a heap or separate a heap into two smaller ones, and the one who takes the last object wins.
     
    Input
    Input contains multiple test cases. The first line is an integer 1 ≤ T ≤ 100, the number of test cases. Each case begins with an integer N, indicating the number of the heaps, the next line contains N integers s[0], s[1], ...., s[N-1], representing heaps with s[0], s[1], ..., s[N-1] objects respectively.(1 ≤ N ≤ 10^6, 1 ≤ S[i] ≤ 2^31 - 1)
     
    Output
    For each test case, output a line which contains either "Alice" or "Bob", which is the winner of this game. Alice will play first. You may asume they never make mistakes.
     
    Sample Input
    2 3 2 2 3 2 3 3
     
    Sample Output
    Alice Bob
     
    Source
     
    Recommend
    gaojie
     
     
     
    这题就是属于Nim博弈的类型。
    可以先看论文了解。
     
    其实就是先求得sg函数,然后n个数的sg值的异或和,为0,则败,非零则赢。
     
    求sg值时打表了100内的,发现大部分是sg[i]=i.
    除了i%4==0  则sg[i]=i-1;
    i%4==3则sg[i]=i+1;
    其余sg[i]=i;
     
     
    //============================================================================
    // Name        : HDU.cpp
    // Author      : 
    // Version     :
    // Copyright   : Your copyright notice
    // Description : Hello World in C++, Ansi-style
    //============================================================================
    
    #include <iostream>
    #include <string.h>
    #include <stdio.h>
    #include <algorithm>
    using namespace std;
    /*
    const int MAXN=1010;
    int sg[MAXN];
    bool vis[MAXN];
    
    int mex(int v)
    {
        if(sg[v]!=-1)return sg[v];
        memset(vis,false,sizeof(vis));
        int tmp;
        tmp=mex(0);
        vis[tmp]=true;
        for(int i=1;i<v;i++)
        {
            tmp=mex(v-i);
            vis[tmp]=true;
            tmp=mex(i)^mex(v-i);
            vis[tmp]=true;
        }
        for(int i=0;i<MAXN;i++)
            if(vis[i]==false)
            {
                sg[v]=i;
                break;
            }
        return sg[v];
    }
    */
    int mex(int v)
    {
        if(v==0)return 0;
        if(v%4==0)return v-1;
        if(v%4==3)return v+1;
        return  v;
    
    }
    int main()
    {
        //freopen("in.txt","r",stdin);
        //freopen("out.txt","w",stdout);
        //memset(sg,-1,sizeof(sg));
        //sg[0]=0;
        int T;
        int n;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%d",&n);
            int ans=0;
            int v;
            while(n--)
            {
                scanf("%d",&v);
                ans^=mex(v);
            }
            if(ans==0)printf("Bob\n");
            else printf("Alice\n");
        }
        return 0;
    }
     
     
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    32-数据链路层,PPP协议
    31-NAT
    30-安全技术,ACL
    ensp实验:配置DHCP
    29-应用层,DHCP协议
    ensp实验:配置stp
    28-STP,选举过程、端口状态、计时器、拓扑变化
    27-交换机,STP
    26-交换机,GVRP
    Manually APK Downgrade for split apks
  • 原文地址:https://www.cnblogs.com/kuangbin/p/3060170.html
Copyright © 2011-2022 走看看