zoukankan      html  css  js  c++  java
  • POJ 2253 Frogger (求每条路径中最大值的最小值,Dijkstra变形)

    Frogger
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 20314   Accepted: 6601

    Description

    Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
    Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
    To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
    The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

    You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

    Input

    The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

    Output

    For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

    Sample Input

    2
    0 0
    3 4
    
    3
    17 4
    19 4
    18 5
    
    0
    

    Sample Output

    Scenario #1
    Frog Distance = 5.000
    
    Scenario #2
    Frog Distance = 1.414
    

    Source

     
     
    这题路径的长度就是经过的最大值,然后求这些最大值的最小值。
     
    变形的Dijkstra算法。
     
     
     
    Dijkstra解法更快:
    //============================================================================
    // Name        : POJ.cpp
    // Author      : 
    // Version     :
    // Copyright   : Your copyright notice
    // Description : Hello World in C++, Ansi-style
    //============================================================================
    
    #include <iostream>
    #include <string.h>
    #include <stdio.h>
    #include <algorithm>
    #include <set>
    #include <queue>
    #include <map>
    #include <vector>
    #include <string>
    #include <math.h>
    using namespace std;
    const int MAXN=210;
    
    pair<int,int>p[MAXN];
    
    double dis(pair<int,int>p1,pair<int,int>p2)
    {
        return sqrt((double)(p1.first-p2.first)*(p1.first-p2.first)+(p2.second-p1.second)*(p2.second-p1.second));
    }
    
    
    const double INF=1e20;
    double cost[MAXN][MAXN];
    double dist[MAXN];
    bool vis[MAXN];
    
    void Dijkstra(int n,int beg)
    {
        for(int i=1;i<=n;i++)
        {
            dist[i]=INF;
            vis[i]=false;
        }
        dist[beg]=0;
        for(int j=0;j<n;j++)
        {
            int k=-1;
            double Min=INF;
            for(int i=1;i<=n;i++)
                if(!vis[i]&&dist[i]<Min)
                {
                    Min=dist[i];
                    k=i;
                }
            if(k==-1)break;
            vis[k]=true;
            for(int i=1;i<=n;i++)
                if(!vis[i]&&max(dist[k],cost[k][i])<dist[i] )
                    dist[i]=max(dist[k],cost[k][i]);
        }
    }
    
    int main()
    {
    //    freopen("in.txt","r",stdin);
    //    freopen("out.txt","w",stdout);
        int n;
        int x,y;
        int iCase=0;
        while(scanf("%d",&n)==1&&n)
        {
            iCase++;
            printf("Scenario #%d\n",iCase);
            for(int i=1;i<=n;i++)
            {
                scanf("%d%d",&x,&y);
                p[i]=make_pair(x,y);
            }
            for(int i=1;i<=n;i++)
                for(int j=i;j<=n;j++)
                {
                    if(i==j)cost[i][j]=dis(p[i],p[j]);
                    else cost[j][i]=cost[i][j]=dis(p[i],p[j]);
                }
            Dijkstra(n,1);
            printf("Frog Distance = %.3f\n\n",dist[2]);
        }
        return 0;
    }
     
     
     
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    算法设计与分析 5.1 合并果子
    算法设计与分析 4.5 洪尼玛与神秘信封
    算法设计与分析 4.4 洪尼玛与魔法卡
    算法设计与分析 4.3 洪尼玛与芒果篮
    算法设计与分析 4.2 洪尼玛与网络攻防战
    算法设计与分析 4.1 洪尼玛与巧克力工厂
    算法设计与分析 3.5 大尾巴狼
    算法设计与分析 3.4 小鲨鱼
    算法设计与分析 3.3 眯眯眼天使
    算法设计与分析 3.2 小绵羊
  • 原文地址:https://www.cnblogs.com/kuangbin/p/3137859.html
Copyright © 2011-2022 走看看