zoukankan      html  css  js  c++  java
  • POJ 1797 Heavy Transportation (Dijkstra算法,求路径的最小值中的最大值)

    Heavy Transportation
    Time Limit: 3000MS   Memory Limit: 30000K
    Total Submissions: 17314   Accepted: 4546

    Description

    Background 
    Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
    Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

    Problem 
    You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

    Input

    The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

    Output

    The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

    Sample Input

    1
    3 3
    1 2 3
    1 3 4
    2 3 5
    

    Sample Output

    Scenario #1:
    4
    

    Source

    TUD Programming Contest 2004, Darmstadt, Germany

    这题每条路径的流量是经过的最小值,求最大流量。

    使用Dijkstra算法的变形,路径长度是经过的最小值,然后是求最大值。

    //============================================================================
    // Name        : POJ.cpp
    // Author      : 
    // Version     :
    // Copyright   : Your copyright notice
    // Description : Hello World in C++, Ansi-style
    //============================================================================
    
    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    #include <algorithm>
    #include <map>
    #include <queue>
    #include <vector>
    #include <string>
    #include <math.h>
    using namespace std;
    const int MAXN=1010;
    const int INF=0x3f3f3f3f;
    int cost[MAXN][MAXN];
    int dist[MAXN];
    bool vis[MAXN];
    
    void Dijkstra(int n,int beg)
    {
        for(int i=1;i<=n;i++)
        {
            dist[i]=0;
            vis[i]=false;
        }
        dist[beg]=INF;
        for(int j=0;j<n;j++)
        {
            int k=-1;
            int Max=0;
            for(int i=1;i<=n;i++)
                if(!vis[i]&&dist[i]>Max)
                {
                    Max=dist[i];
                    k=i;
                }
            if(k==-1)break;
            vis[k]=true;
            for(int i=1;i<=n;i++)
                if(!vis[i]&&min(dist[k],cost[k][i])>dist[i] )
                    dist[i]=min(dist[k],cost[k][i]);
        }
    }
    
    int main()
    {
    //    freopen("in.txt","r",stdin);
    //    freopen("out.txt","w",stdout);
        int T;
        int n,m;
        scanf("%d",&T);
        int iCase=0;
        while(T--)
        {
            iCase++;
            scanf("%d%d",&n,&m);
            memset(cost,0,sizeof(cost));
            int u,v,w;
            while(m--)
            {
                scanf("%d%d%d",&u,&v,&w);
                cost[u][v]=cost[v][u]=max(cost[u][v],w);
            }
            Dijkstra(n,1);
            printf("Scenario #%d:\n",iCase);
            printf("%d\n\n",dist[n]);
        }
        return 0;
    }
    人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想
  • 相关阅读:
    Ubuntu Server中怎样卸载keepalived
    Winform中实现ZedGraph滚轮缩放后自动重新加载数据
    Winform中自定义添加ZedGraph右键实现设置所有Y轴刻度的上下限
    C#中获取多个对象list中对象共有的属性项
    Windows7中启动Mysql服务时提示:拒绝访问的一种解决方式
    八、子查询实践
    四、bootstrap-Table
    二、sql新增后返回主键|sql 使用 FOR XML PATH实现字符串拼接|sql如果存在就修改不存在就新增
    一、动词、名词、形容词汇位置
    三、TortoiseSVN 单独拉取项目某个文件
  • 原文地址:https://www.cnblogs.com/kuangbin/p/3137862.html
Copyright © 2011-2022 走看看