zoukankan      html  css  js  c++  java
  • HDUOJ

    Integer Inquiry

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 13470    Accepted Submission(s): 3382


    Problem Description
    One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
    ``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)
     

    Input
    The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

    The final input line will contain a single zero on a line by itself.
     

    Output
    Your program should output the sum of the VeryLongIntegers given in the input.


    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.
     

    Sample Input
    1 123456789012345678901234567890 123456789012345678901234567890 123456789012345678901234567890 0
     

    Sample Output
    370370367037037036703703703670
     
    为了A高精度的题目,最近”快速入门“了java...
    C++还是主要的语言,java只A高精度

    import java.io.*;
    import java.math.*;
    import java.util.*;
    import java.text.*;
    
    public class Main {
    
    	public static void main(String[] args) {
    		Scanner cin = new Scanner(System.in);
    		int N, n;
    		N = cin.nextInt();
    		for(n = 1; n <= N; n++){
    			BigInteger x;
    			BigInteger sum = new BigInteger("0");
    			if(n!=1)
    				System.out.println();
    			while(true){
    				x = cin.nextBigInteger();
    				if(!x.equals(BigInteger.valueOf(0)))
    					sum = sum.add(x);
    				else{
    					System.out.println(sum.toString());
    					break;
    				}
    			}
    		}
    	}
    	
    }
    



  • 相关阅读:
    postfix队列管理
    fdisk添加磁盘
    postfix日志分析pflogsumm
    ioctl接口内容操作
    linux 路由表设置 之 route 指令详解
    手把手教你用 Strace 诊断问题
    rtsp学习----海康RTSP客户端连接深入分析
    栈回溯技术
    objdump命令
    linux中的strip命令简介------给文件脱衣服
  • 原文地址:https://www.cnblogs.com/kunsoft/p/5312764.html
Copyright © 2011-2022 走看看