zoukankan      html  css  js  c++  java
  • POJ 1002 4873279 map

    487-3279
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 287874   Accepted: 51669

    Description

    Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

    The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

    A, B, and C map to 2 
    D, E, and F map to 3 
    G, H, and I map to 4 
    J, K, and L map to 5 
    M, N, and O map to 6 
    P, R, and S map to 7 
    T, U, and V map to 8 
    W, X, and Y map to 9 

    There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

    Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

    Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

    Input

    The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

    Output

    Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

    No duplicates. 

    Sample Input

    12
    4873279
    ITS-EASY
    888-4567
    3-10-10-10
    888-GLOP
    TUT-GLOP
    967-11-11
    310-GINO
    F101010
    888-1200
    -4-8-7-3-2-7-9-
    487-3279
    

    Sample Output

    310-1010 2
    487-3279 4
    888-4567 3

    Source

    这个题目的大概意思是找相同号码出现的次数,其中要注意的是他有个对应规则
    A, B, and C map to 2 (map to 就是对应的意思,即A,B,C相当于为2)
    D, E, and F map to 3 
    G, H, and I map to 4 
    J, K, and L map to 5 
    M, N, and O map to 6 
    P, R, and S map to 7 
    T, U, and V map to 8 
    W, X, and Y map to 9 
    注意没有Q和Z 在初始化时可以直接将其定义为0
    最后输出的时候只输出大于等于2次的号码
    注意如果都没有两次的话要输出
    No duplicates. 
    再提醒一下最好用数字存,用字符串存可能会时间超限,至少我用字符串做的前面几次都时间超限了。
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cstdio>
    #include <map>
    #include <string>
    using namespace std;
    int num[]=//初始化每个字母对应的值
    {
        2,2,2,
        3,3,3,
        4,4,4,
        5,5,5,
        6,6,6,
        7,0,7,7,
        8,8,8,
        9,9,9,
    };
    map<int,int>s;
    char buf[128];
    int main()
    {
        int t;
        cin >> t;
        bool flag = false;
        for(int i=0;i<t;i++)
        {
            cin >> buf;
            int c = 0;
            for(int j=0;buf[j];j++)//用数直接存下号码
            {
                if(isdigit(buf[j]))
                   c = c*10+buf[j]-'0';
                else if(isalpha(buf[j]))
                   c = c*10+num[buf[j]-'A'];
            }
            s[c]++;
        }
        for(map<int,int>::iterator it = s.begin();it!=s.end();it++)
            if(it->second > 1)
            {
                flag = true;
                printf("%03d-%04d %d\n",it->first/10000,it->first%10000,it->second);//注意输出时可以通过取余,除以10000来输出后四位,前四位,加个0避免省略0的情况,这种方法个人觉得挺好的
            }
        if(!flag)
        puts("No duplicates.");
        return 0;
    }
    彼时当年少,莫负好时光。
  • 相关阅读:
    log4j
    hashContext
    sql语句
    css样式
    作业七:(二)疑问解答
    作业七:(1)翻译
    结对编程作业
    软件优缺点评价(补交)
    C#程序分析
    VS2013安装及测试练习
  • 原文地址:https://www.cnblogs.com/l609929321/p/6545173.html
Copyright © 2011-2022 走看看