zoukankan      html  css  js  c++  java
  • HDU 1213 How Many Tables

    How Many Tables

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 28256    Accepted Submission(s): 13990


    Problem Description
    Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

    One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

    For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
     
    Input
    The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
     
    Output
    For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
     
    Sample Input
    2 5 3 1 2 2 3 4 5 5 1 2 5
     
    Sample Output
    2 4
     
    Author
    Ignatius.L
     
    Source
     
    Recommend
    Eddy
    简单的并查集应用
    就是看有几个连通图,用并查集求求他们的集合(不同连通图不同集合)就可以了
    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int pre[1010],t[1010];
    int find(int x)
    {
        int r = x;
        while(r!=pre[r])
            r = pre[r];
        return r;
    }
    void join(int x,int y)
    {
        int fx=find(x),fy=find(y);
        if(fx!=fy)
        {
            pre[fy] = fx;
        }
    }
    int main()
    {
        int p;
        cin >> p;
        while(p--)
        {
            int m,n;
            cin >> n >> m;
            for(int i=1; i<=n; i++)
            {
                pre[i] = i;
                t[i] = 0;
            }
            while(m--)
            {
                int a,b;
                cin >> a >> b;
                join(a,b);
            }
            for(int i=1; i<=n; i++)
            {
                t[find(i)]=1;
            }
            int num,i;
            for(num=0,i=1; i<=n; i++)
                if(t[i])
                    num++;
            cout << num << endl;
        }
        return 0;
    }
    彼时当年少,莫负好时光。
  • 相关阅读:
    linux自动获得mac地址,修改网络配置
    Linux上java环境变量配置
    linux下rz,sz安装
    linux环境变量设置
    cenos6.5安装vsftp
    tomcat打开gzip、配置utf-8
    java基础50 配置文件类(Properties)
    java基础49 IO流技术(对象输入流/对象输出流)
    java基础48 IO流技术(序列流)
    java基础47 装饰着模式设计
  • 原文地址:https://www.cnblogs.com/l609929321/p/6561979.html
Copyright © 2011-2022 走看看