zoukankan      html  css  js  c++  java
  • POJ 1129 Channel Allocation

    Channel Allocation
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 15344   Accepted: 7783

    Description

    When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 
    Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

    Input

    The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 
    Following the number of repeaters is a list of adjacency relationships. Each line has the form: 
    A:BCDH 
    which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 
    A: 
    The repeaters are listed in alphabetical order. 
    Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

    Output

    For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

    Sample Input

    2
    A:
    B:
    4
    A:BC
    B:ACD
    C:ABD
    D:BC
    4
    A:BCD
    B:ACD
    C:ABD
    D:ABC
    0

    Sample Output

    1 channel needed.
    3 channels needed.
    4 channels needed. 

    Source

     
    这是个染色问题   n:后面的每一个m即为与n相邻的区域,而相邻的区域所用颜色不能相同,最后求染完所有区域所需要的颜色种数
    #include<stdio.h>
    #include<string.h>
    #include<algorithm>
    #include<iostream>
    #define maxn 50
    using namespace std;
    int n;
    int ans,tmp;
    int mapn[maxn][maxn],color[maxn];
    char str[50];
    int ok(int a,int b)
    {
        for(int i=0;i<n;i++)
        {
            if(mapn[i][a]&&b==color[i])
                return 0;
        }
        return 1;
    }
    void dfs(int m,int num)
    {
        if(tmp == 1)
            return;
        if(m>=n)//注意结束标志,当m大于等于n时回溯所有都结束
        {
            tmp = 1;
            return;
        }
        for(int i=1;i<=num;i++)
        {
            if(ok(m,i))//判断区域是否相邻
            {
                color[m] = i;
                dfs(m+1,num);
                color[m] = 0;
            }
        }
        if(tmp == 0)//有一个tmp不等于0就加一种颜色
        {
            ans++;
            dfs(m,num+1);
        }
    }
    int main()
    {
        while(~scanf("%d",&n))
        {
            if(n==0)
                break;
            tmp = 0;
            ans = 1;
            memset(color,0,sizeof(color));
            memset(mapn,0,sizeof(mapn));
            int d = n;
            while(d--)
            {
                cin >> str;
                int a = str[0] - 'A';
                for(int i=2; i<strlen(str); i++)
                {
                    int b = str[i] - 'A';
                    mapn[a][b] = 1;
                    mapn[b][a] = 1;
                }
            }
            dfs(0,1);
            if(ans==1)
                cout << "1 channel needed." << endl;
            else cout << ans << " channels needed." << endl;
        }
        return 0;
    }
    彼时当年少,莫负好时光。
  • 相关阅读:
    Atitti 图像处理 图像混合 图像叠加 blend 原理与实现
    Atitit Gaussian Blur 高斯模糊 的原理and实现and 用途
    Atitit 图像处理 灰度图片 灰度化的原理与实现
    Atitit (Sketch Filter)素描滤镜的实现  图像处理  attilax总结
    Atitit 实现java的linq 以及与stream api的比较
    Atitit attilax在自然语言处理领域的成果
    Atitit 图像处理 常用8大滤镜效果 Jhlabs 图像处理类库 java常用图像处理类库
    Atitit 图像处理--图像分类 模式识别 肤色检测识别原理 与attilax的实践总结
    Atitit apache 和guava的反射工具
    atitit。企业的价值观 员工第一 vs 客户第一.docx
  • 原文地址:https://www.cnblogs.com/l609929321/p/6690713.html
Copyright © 2011-2022 走看看