zoukankan      html  css  js  c++  java
  • 1014 装箱问题 CODE[VS]

    1014 装箱问题

     

    2001年NOIP全国联赛普及组

     时间限制: 1 s
     空间限制: 128000 KB
     题目等级 : 黄金 Gold
     
     
    题目描述 Description

    有一个箱子容量为V(正整数,0<=V<=20000),同时有n个物品(0<n<=30),每个物品有一个体积(正整数)。

    要求n个物品中,任取若干个装入箱内,使箱子的剩余空间为最小。

    输入描述 Input Description

    一个整数v,表示箱子容量

    一个整数n,表示有n个物品

    接下来n个整数,分别表示这n 个物品的各自体积

    输出描述 Output Description

    一个整数,表示箱子剩余空间。

    样例输入 Sample Input

    24

    6

    8

    3

    12

    7

    9

    7

    样例输出 Sample Output

    0

    #include<iostream>
    #include<cstdio>
    using namespace std;
    
    bool f[20001];//f[i]箱子还剩i时的最优解
    int a[31];
    int v,n;
    
    int main()
    {
        f[0]=1;
        scanf("%d%d",&v,&n);
        for(int i=1;i<=n;++i)
        {
            scanf("%d",&a[i]);
        }
        for(int i=1;i<=n;++i)
        {
            for(int j=v;j>=0;--j)
            {
                if(f[j]&&j+a[i]<=v)//DP
                {
                    f[j+a[i]]=1;//能装到的体积就打个1
                }
            }
        }
        for(int j=v;j>=0;--j)
        {
            if(f[j])
            {
                cout<<v-j<<endl;
                return 0;
            }
        }
    }
    彼时当年少,莫负好时光。
  • 相关阅读:
    gvim : invalid input string
    端口
    Sequence Overview
    vi的使用
    Ubuntu安装CodeBlocks相关问题总结
    中断
    Ubuntu Software Repository
    UVA 12299 RMQ with Shifts
    UVA 12293 Box Game
    POJ 3468 A Simple Problem with Integers (1)
  • 原文地址:https://www.cnblogs.com/l609929321/p/6705693.html
Copyright © 2011-2022 走看看