zoukankan      html  css  js  c++  java
  • Hangman Judge UVA

    In ``Hangman Judge,'' you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

    1. The contestant tries to solve to puzzle by guessing one letter at a time.
    2. Every time a guess is correct, all the characters in the word that match the guess will be ``turned over.'' For example, if your guess is ``o'' and the word is ``book'', then both ``o''s in the solution will be counted as ``solved.''
    3. Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.
      ______   
         |  |     
         |  O     
         | /|    
         |  |     
         | /     
       __|_       
       |   |______
       |_________|
    4. If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.
    5. If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.
    6. If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

    Your task as the ``Hangman Judge'' is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

    Input

    Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of -1 would indicate the end of all games (and input).

    Output

    The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

    You win.
    You lose.
    You chickened out.

    Sample Input

    1
    cheese
    chese
    2
    cheese
    abcdefg
    3
    cheese
    abcdefgij
    -1

    Sample Output

    Round 1
    You win.
    Round 2
    You chickened out.
    Round 3
    You lose.
    先贴一份用字符串做错的代码把
    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #define maxn 105
    using namespace std;
    int main()
    {
        int n;
        while(cin >> n)
        {
            if(n==-1)
                break;
            char str1[maxn],str2[maxn];
            cin >> str1 >> str2;
            int num = 0;
            int flg = 1;
            for(int i=0;i<strlen(str2);i++)
            {
                int flag = 0;
                if(num>=7)
                    break;
                for(int j=0;j<strlen(str1);j++)
                {
                    if(str2[i] == str1[j])
                    {
                        flag = 1;
                        int k;
                        for(k=j;k<strlen(str1)-1;k++)
                        {
                            str1[k] = str1[k+1];
                        }
                        str1[k] = '';
                        break;
                    }
                }
                if(!flag)
                {
                    num++;
                    flg = 0;
                }
            }
            if(num>=7)
            {
                cout << "Round " << n << endl;
                cout << "You lose." << endl;
            }
            else
            {
                if(flg)
                {
                    cout << "Round " << n << endl;
                    cout << "You win." << endl;
                }
                else
                {
                    cout << "Round " << n << endl;
                    cout << "You chickened out." << endl;
                }
            }
        }
        return 0;
    }

    在师傅的提醒下用set做的...

    #include<iostream>
    #include<cstring>
    #include<cstdio>
    #include<set>
    using namespace std;
    int main()
    {
        int n;
        while(cin >> n)
        {
            if(n==-1)
                break;
            string str1,str2;
            cin >> str1 >> str2;
            int num = 0;
            set<char> s;
            for(int i=0;i<str1.length();i++)
                s.insert(str1[i]);//用set简单很多,用字符串老是错。。
            for(int i=0;i<str2.length();i++)
            {
                if(!s.size() || num>=7)
                    break;
                if(s.find(str2[i]) == s.end())
                    num++;
                else s.erase(str2[i]);
            }
            if(num>=7)
            {
                cout << "Round " << n << endl;
                cout << "You lose." << endl;
            }
            else
            {
                if(!s.size())
                {
                    cout << "Round " << n << endl;
                    cout << "You win." << endl;
                }
                else
                {
                    cout << "Round " << n << endl;
                    cout << "You chickened out." << endl;
                }
            }
        }
        return 0;
    }
    彼时当年少,莫负好时光。
  • 相关阅读:
    利用反射获取类的所有字段
    System.Data.Entity.Internal.AppConfig 类型初始值设定项引发异常
    sql server 修改列类型
    sql server 删除表字段和字段的约束
    sql server 查找字段上的约束
    ASP.NET MVC自定义路由
    初探pandas——索引和查询数据
    初探pandas——安装和了解pandas数据结构
    初探numpy——numpy常用通用函数
    初探numpy——广播和数组操作函数
  • 原文地址:https://www.cnblogs.com/l609929321/p/6838080.html
Copyright © 2011-2022 走看看