zoukankan      html  css  js  c++  java
  • 2017 ACM/ICPC Asia Regional Qingdao Online 1003 The Dominator of Strings hdu 6208

    The Dominator of Strings

    Time Limit: 3000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
    Total Submission(s): 0    Accepted Submission(s): 0


    Problem Description
    Here you have a set of strings. A dominator is a string of the set dominating all strings else. The string S is dominated by T if S is a substring of T.
     
    Input
    The input contains several test cases and the first line provides the total number of cases.
    For each test case, the first line contains an integer N indicating the size of the set.
    Each of the following N lines describes a string of the set in lowercase.
    The total length of strings in each case has the limit of 100000.
    The limit is 30MB for the input file.
     
    Output
    For each test case, output a dominator if exist, or No if not.
     
    Sample Input
    3 10 you better worse richer poorer sickness health death faithfulness youbemyweddedwifebetterworsericherpoorersicknesshealthtilldeathdouspartandpledgeyoumyfaithfulness 5 abc cde abcde abcde bcde 3 aaaaa aaaab aaaac
     
    Sample Output
    youbemyweddedwifebetterworsericherpoorersicknesshealthtilldeathdouspartandpledgeyoumyfaithfulness abcde No
     
    Source
    输入输出测试
    #include <bits/stdc++.h>
    #define IO ios::sync_with_stdio(false); cin.tie(0)
    using namespace std ;
    vector<string> dic ;
    string str ,tp ;
    int main()
    {
        IO;
        int t,n;
    
        cin >> t ;
        while(t--)
        {
            int n , len = -1 , buf ;
            cin >> n ;
            dic.clear() ;
            for(int i = 0 ; i < n ; i++ )
            {
                cin >> tp ;
                dic.push_back(tp) ;
                int x = tp.length();
                if( x > len )
                {
                    len = x ;
                    str = tp ;
                }
            }
    
            bool flag = true ;
            for( int i = 0 ; i < n ; i++ )
            {
    
                if( str.find(dic[i]) == string::npos )
                {
                    flag = false ;
                    break ;
                }
            }
            if( flag )
            {
                cout << str << endl ;
            }
            else
            {
                cout << "No" <<endl ;
            }
        }
        return 0;
    }
    彼时当年少,莫负好时光。
  • 相关阅读:
    thinkphp3.1.3验证码优化
    php导出数据为CSV文件DEMO
    python学习笔记十七:base64及md5编码
    linux运维笔记
    [转]如何像Python高手(Pythonista)一样编程
    用gulp清除、移动、压缩、合并、替换代码
    [蓝桥杯][2017年第八届真题]小计算器(模拟)
    [蓝桥杯][2017年第八届真题]发现环(基环树输出环)
    [蓝桥杯][2017年第八届真题]合根植物(并查集)
    省赛训练5-3(四个签到题)
  • 原文地址:https://www.cnblogs.com/l609929321/p/7538043.html
Copyright © 2011-2022 走看看