zoukankan      html  css  js  c++  java
  • A

    Description

    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now. 



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path. 
    Your task is to output the maximum value according to the given chessmen list. 

    Input

    Input contains multiple test cases. Each test case is described in a line as follow: 
    N value_1 value_2 …value_N 
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int. 
    A test case starting with 0 terminates the input and this test case is not to be processed. 

    Output

    For each case, print the maximum according to rules, and one line one case. 

    Sample Input

    3 1 3 2
    4 1 2 3 4
    4 3 3 2 1
    0

    Sample Output

    4
    10
    3

    题意:一开始对题意不是很明确,看了别人的翻译才明白题目的意思。

    知识点:最大上升子序列求和。。。从前往后搜

    状态转移方程:dp[i]=max(dp[i],dp[j]+a[i])

    AC代码:

    解法一:

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    int dp[1005],a[1005];
    int main ()
    {
    int n,i,j,max;
    while(scanf("%d",&n)!=EOF&&n)
    {
    max=-999;
    memset(a,0,sizeof(a));
    for(i=1;i<=n;i++)
    scanf("%d",&a[i]);
    memset(dp,0,sizeof(dp));
    for(i=1;i<=n;i++)
    {
    dp[i]=a[i];
    for(j=1;j<=i;j++)
    {
    if(a[j]<a[i]&&dp[i]<dp[j]+a[i])//状态转移方程:dp[i]=max(dp[i],dp[j]+a[i])
    dp[i]=dp[j]+a[i];
    }
    if(max<dp[i])
    max=dp[i];

    }
    printf("%d ",max);
    }

    return 0;
    }



    解法二:

    #include <iostream> #include<cstdio> #include<cstring> using namespace std; int a[1005],d[1005]; int max(int a,int b) { return a>b?a:b; } int main() { int n,sum; memset(d,0,sizeof(d)); while(~scanf("%d",&n)&&n) { for(int i=1;i<=n;i++) scanf("%d",&a[i]); for(int i=1;i<=n;i++) { sum=-999; for(int j=0;j<i;j++) { if(a[i]>a[j]) sum=max(d[j],sum); } d[i]=sum+a[i]; } sum=-999; for(int i=1;i<=n;i++) { if(sum<d[i]) sum=d[i]; } printf("%d ",sum); } return 0;
  • 相关阅读:
    Android 获取内存信息
    Android上基于libgdx的游戏开发资料
    Android使用http协议与服务器通信
    Android 下载zip压缩文件并解压
    2014年终总结
    OSG 坑爹的Android example
    支持Android 的几款开源3D引擎调研
    利用Android NDK编译lapack
    Django 中实现连接多个数据库并实现读写分离
    Git之多人协同开发
  • 原文地址:https://www.cnblogs.com/lbyj/p/5758037.html
Copyright © 2011-2022 走看看