zoukankan      html  css  js  c++  java
  • 周赛 POJ 3934 Queue

    Description

    Linda is a teacher in ACM kindergarten. She is in charge of n kids. Because the dinning hall is a little bit far away from the classroom, those n kids have to walk in line to the dinning hall every day. When they are walking in line, if and only if two kids can see each other, they will talk to each other. Two kids can see each other if and only if all kids between them are shorter then both of them, or there are no kids between them. Kids do not only look forward, they may look back and talk to kids behind them. Linda don’t want them to talk too much (for it’s not safe), but she also don’t want them to be too quiet(for it’s boring), so Linda decides that she must form a line in which there are exactly m pairs of kids who can see each other. Linda wants to know, in how many different ways can she form such a line. Can you help her? 

    Note: All kids are different in height.

    Input

    Input consists of multiple test cases. Each test case is one line containing two integers. The first integer is n, and the second one is m. (0 < n <= 80, 0 <= m <= 10000). 
    Input ends by a line containing two zeros.

    Output

    For each test case, output one line containing the reminder of the number of ways divided by 9937. 

    Sample Input

    1 0
    2 0
    3 2
    0 0

    Sample Output

    1
    0
    4

    答案要模上9937,都会想到是递推吧,关键怎么推。

    思路:i个人j对可由    1:i-1个人j-2对再插入一个最小的人,所以对原来的组合没有影响       2:i-2个人j-1对,再在两边插入一个人,对原来的组合也没有影响。

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<limits.h>
    using namespace std;
    const int M=9937;
    int dp[85][10005];
    void init()
    {
        dp[1][0]=1;
        dp[2][1]=2;
        for(int i=3;i<=80;i++)
        {
            for(int j=0;j<=10000;j++)
            {
                if(j>=2)
                    dp[i][j]=(dp[i-1][j-2]*(i-2))%M;
                if(j>=1)
                    dp[i][j]=(dp[i][j]+dp[i-1][j-1]*2)%M;
            }
        }
    }
    int main()
    {
        init();
        int n,m;
        while(cin>>n>>m)
        {
            if(n==0&&m==0)
                break;
            cout<<dp[n][m]<<endl;
        }
        return 0;
    }
    


  • 相关阅读:
    go语言学习之从例子开始
    分享一个不错的Unittest测试报告
    selenium各种定位方法(转)
    HTMLTESTRunner自动化测试报告增加截图功能
    selenium之chrome驱动版本
    Python基础(六) python生成xml测试报告
    vue+elementUI 表头按钮
    vue+elementUI滚动条
    vue表格表头添加按钮
    elementUI升级版本后Dialog弹空不显示问题
  • 原文地址:https://www.cnblogs.com/lcchuguo/p/3995090.html
Copyright © 2011-2022 走看看