zoukankan      html  css  js  c++  java
  • HDU1042---N!

    N!

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
    Total Submission(s): 77404    Accepted Submission(s): 22617


    Problem Description
    Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
     

    Input
    One N in one line, process to the end of file.
     

    Output
    For each N, output N! in one line.
     

    Sample Input
    1 2 3
     

    Sample Output
    1 2 6
     
    Java大数水一发:
    import java.math.BigInteger;
    import java.util.Scanner;
    
    public class Main {
    
    	public static void main(String[] args) {
    		// TODO Auto-generated method stub
    		Scanner s = new Scanner(System.in);
    		while(s.hasNext()) {
    			BigInteger bi = new BigInteger("1");
    			int t = s.nextInt();
    			for(int i=1;i<=t;i++) {
    				String ss = i + "";
    				BigInteger t1 = new BigInteger(ss);
    				bi=bi.multiply(t1);
    			}
    			System.out.println(bi);
    		}	
    		s.close();
    	}
    }
    


  • 相关阅读:
    ACM-生化武器
    ACM-Antiprime数
    ACM-寻宝
    ACM-小偷的背包
    ACM-吴奶奶买鱼
    ACM-挑战题之排列生成
    ACM-数细胞
    ACM-售货员难题
    学习《linux》课程
    MATLAB 求圆形面积
  • 原文地址:https://www.cnblogs.com/lemonbiscuit/p/7776046.html
Copyright © 2011-2022 走看看