zoukankan      html  css  js  c++  java
  • poj 3620 Avoid The Lakes

    Description

    Farmer John's farm was flooded in the most recent storm, a fact only aggravated by the information that his cows are deathly afraid of water. His insurance agency will only repay him, however, an amount depending on the size of the largest "lake" on his farm.

    The farm is represented as a rectangular grid with N (1 ≤ N ≤ 100) rows and M (1 ≤ M ≤ 100) columns. Each cell in the grid is either dry or submerged, and exactly K (1 ≤ KN × M) of the cells are submerged. As one would expect, a lake has a central cell to which other cells connect by sharing a long edge (not a corner). Any cell that shares a long edge with the central cell or shares a long edge with any connected cell becomes a connected cell and is part of the lake.

    Input

    * Line 1: Three space-separated integers: N, M, and K
    * Lines 2..K+1: Line i+1 describes one submerged location with two space separated integers that are its row and column: R and C

    Output

    * Line 1: The number of cells that the largest lake contains. 

    Sample Input

    3 4 5
    3 2
    2 2
    3 1
    2 3
    1 1

    Sample Output

    4
    
    
    
    
    
    #include <iostream>
    #include <string.h>
    using namespace std;
    int a[105][105],ma[1000];
    int m,n,k,p1;
    int so(int x1,int y1)
    {a[x1][y1]=0;ma[p1]++;
     if( y1<n&&a[x1][y1+1]==1)
    {so(x1,y1+1);}
    if( x1<m&&a[x1+1][y1]==1)
    {so(x1+1,y1);}
    
    
    if(y1>0&&a[x1][y1-1]==1)
    {so(x1,y1-1);}
     if(x1>0&&a[x1-1][y1]==1)
    {so(x1-1,y1);}
     
     return 0;
    }
    
    
    int main()
    {int i,j;
    
    
    cin>>m>>n>>k;
    int x,y;
    for(i=0;i<m;i++)
    for(j=0;j<n;j++)
    a[i][j]=0;
    for(i=0;i<k;i++)
    {cin>>x>>y;
    a[x][y]=1;
    }
    
    
    
    memset(ma,0,sizeof(ma));
     p1=0;
    for(i=1;i<=m;i++)
        for(j=1;j<=n;j++)
    {
    
        if(a[i][j]==1)
     {so(i,j);
    p1++;
     }
    }
    int max1=0;
    for(i=0;i<1000;i++)
    if(ma[i]>max1)
        max1=ma[i];
    cout<<max1<<endl;
    return 0;
    }
    



  • 相关阅读:
    Realtime crowdsourcing
    maven 常用插件汇总
    fctix
    sencha extjs4 command tools sdk
    首次吃了一颗带奶糖味的消炎药,不知道管用不
    spring mvc3 example
    ubuntu ati driver DO NOT INSTALL recommand driver
    yet another js editor on windows support extjs
    how to use springsource tools suite maven3 on command
    ocr service
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387794.html
Copyright © 2011-2022 走看看