Description
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.
You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.
Input
Output
Sample Input
2 0 0 3 4 3 17 4 19 4 18 5 0
Sample Output
Scenario #1 Frog Distance = 5.000 Scenario #2 Frog Distance = 1.414
Hint
#include <iostream>
#include <iomanip>
#include <cmath>
using namespace std;
class point
{public:
int x,y;}p[201];
double pa[201][201];
int main()
{
int t=1,n;
while(cin>>n,n!=0)
{int i,j,k;
for(i=1;i<=n;i++)
cin>>p[i].x>>p[i].y;
for(i=1;i<=n-1;i++)
for(j=i+1;j<=n;j++)
{
double x1=p[i].x-p[j].x;
double y1=p[i].y-p[j].y;
pa[i][j]=pa[j][i]=sqrt(x1*x1+y1*y1);
}
for(k=1;k<=n;k++)
for(i=1;i<=n-1;i++)
for(j=i+1;j<=n;j++)
{
if(pa[i][k]<pa[i][j] && pa[k][j]<pa[i][j])
if(pa[i][k]<pa[k][j])
pa[i][j]=pa[j][i]=pa[k][j];
else
pa[i][j]=pa[j][i]=pa[i][k];
}
cout<<"Scenario #"<<t++<<endl;
cout<<fixed<<setprecision(3)<<"Frog Distance = "<<pa[1][2]<<endl<<endl;
}
return 0;}