zoukankan      html  css  js  c++  java
  • Frogger

    Description

    Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
    Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
    To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
    The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

    You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

    Input

    The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

    Output

    For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

    Sample Input

    2
    0 0
    3 4
    
    3
    17 4
    19 4
    18 5
    
    0
    

    Sample Output

    Scenario #1
    Frog Distance = 5.000
    
    Scenario #2
    Frog Distance = 1.414
    

    Hint

    #include <iostream>
    #include <iomanip>
    #include <cmath>
    using namespace std;
    class point
    {public:
    int x,y;}p[201];
    double pa[201][201];
    int main()
    {
    int t=1,n;
    while(cin>>n,n!=0)
    {int i,j,k;
    for(i=1;i<=n;i++)
    cin>>p[i].x>>p[i].y;
    for(i=1;i<=n-1;i++)
    for(j=i+1;j<=n;j++)
    {

    double x1=p[i].x-p[j].x; 
     double y1=p[i].y-p[j].y; 
    pa[i][j]=pa[j][i]=sqrt(x1*x1+y1*y1);

    }

    for(k=1;k<=n;k++)
    for(i=1;i<=n-1;i++)
    for(j=i+1;j<=n;j++)
    {
    if(pa[i][k]<pa[i][j] && pa[k][j]<pa[i][j])    
                            if(pa[i][k]<pa[k][j])           
                                pa[i][j]=pa[j][i]=pa[k][j]; 
                            else 
                                pa[i][j]=pa[j][i]=pa[i][k]; 


    }

    cout<<"Scenario #"<<t++<<endl; 

    cout<<fixed<<setprecision(3)<<"Frog Distance = "<<pa[1][2]<<endl<<endl; 

    }

    return 0;}

  • 相关阅读:
    IsBadReadPtr|IsBadWritePtr调试崩溃
    VSCode配置python调试环境
    Visual Studio Code 如何编写运行 C、C++ 程序?
    使用nginx做反向代理
    Win10环境下配置VScode的C++编译环境
    关于java 获取 html select标签 下拉框 option 文本内容 隐藏域
    【VSCode】Windows下VSCode编译调试c/c++【更新 2018.03.27】
    VS Code 配置 C/C++ 环境
    改变你一生的编辑器:VSCode使用总结
    CentOS7,安装Tomcat8.5、JDK1.8,并设置开机启动(Linux CentOS Tomcat、JDK+Tomcat、Tomcat开机自启动)
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387799.html
Copyright © 2011-2022 走看看