zoukankan      html  css  js  c++  java
  • Message Decowding

    Description

    The cows are thrilled because they've just learned about encrypting messages. They think they will be able to use secret messages to plot meetings with cows on other farms.

    Cows are not known for their intelligence. Their encryption method is nothing like DES or BlowFish or any of those really good secret coding methods. No, they are using a simple substitution cipher.

    The cows have a decryption key and a secret message. Help them decode it. The key looks like this:
            yrwhsoujgcxqbativndfezmlpk

    Which means that an 'a' in the secret message really means 'y'; a 'b' in the secret message really means 'r'; a 'c' decrypts to 'w'; and so on. Blanks are not encrypted; they are simply kept in place.

    Input text is in upper or lower case, both decrypt using the same decryption key, keeping the appropriate case, of course.

    Input

    * Line 1: 26 lower case characters representing the decryption key

    * Line 2: As many as 80 characters that are the message to be decoded

    Output

    * Line 1: A single line that is the decoded message. It should have the same length as the second line of input.

    Sample Input

    eydbkmiqugjxlvtzpnwohracsf
    Kifq oua zarxa suar bti yaagrj fa xtfgrj
    

    Sample Output

    Jump the fence when you seeing me coming
    

    Hint


    #include <iostream>
    #include <map>
    using namespace std;
    char a[26],b[1000];

    int main()
    {
     int i;
     map<char,char>m;
     map<char, char >::iterator  kan;
     cin>>a;
     for(i=0;i<26;i++)
     {
      m['a'+i]=a[i];
      
     }
     getchar();
     gets(b);
     i=0;
     while(b[i]!='')
     { if(b[i]==' ')
       cout<<" ";
      else if(b[i]>='A'&&b[i]<='Z')
      {b[i]=b[i]+32;
      kan=m.find(b[i]);
      cout<<char(kan->second-32);
      }
     
      else{
      kan=m.find(b[i]);
      cout<<kan->second;
      }
      i++;
     }
     cout<<endl;
     return 0;
    }

  • 相关阅读:
    [CF1039D]You Are Given a Tree
    [洛谷P2107]小Z的AK计划
    [CF409F]000001
    [洛谷P1801]黑匣子_NOI导刊2010提高(06)
    [洛谷P3377]【模板】左偏树(可并堆)
    [洛谷P2482][SDOI2010]猪国杀
    [CF45G]Prime Problem
    [CF735D]Taxes
    [洛谷P3413]SAC#1
    [洛谷P4124][CQOI2016]手机号码
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387825.html
Copyright © 2011-2022 走看看