zoukankan      html  css  js  c++  java
  • Message Decowding

    Description

    The cows are thrilled because they've just learned about encrypting messages. They think they will be able to use secret messages to plot meetings with cows on other farms.

    Cows are not known for their intelligence. Their encryption method is nothing like DES or BlowFish or any of those really good secret coding methods. No, they are using a simple substitution cipher.

    The cows have a decryption key and a secret message. Help them decode it. The key looks like this:
            yrwhsoujgcxqbativndfezmlpk

    Which means that an 'a' in the secret message really means 'y'; a 'b' in the secret message really means 'r'; a 'c' decrypts to 'w'; and so on. Blanks are not encrypted; they are simply kept in place.

    Input text is in upper or lower case, both decrypt using the same decryption key, keeping the appropriate case, of course.

    Input

    * Line 1: 26 lower case characters representing the decryption key

    * Line 2: As many as 80 characters that are the message to be decoded

    Output

    * Line 1: A single line that is the decoded message. It should have the same length as the second line of input.

    Sample Input

    eydbkmiqugjxlvtzpnwohracsf
    Kifq oua zarxa suar bti yaagrj fa xtfgrj
    

    Sample Output

    Jump the fence when you seeing me coming
    

    Hint


    #include <iostream>
    #include <map>
    using namespace std;
    char a[26],b[1000];

    int main()
    {
     int i;
     map<char,char>m;
     map<char, char >::iterator  kan;
     cin>>a;
     for(i=0;i<26;i++)
     {
      m['a'+i]=a[i];
      
     }
     getchar();
     gets(b);
     i=0;
     while(b[i]!='')
     { if(b[i]==' ')
       cout<<" ";
      else if(b[i]>='A'&&b[i]<='Z')
      {b[i]=b[i]+32;
      kan=m.find(b[i]);
      cout<<char(kan->second-32);
      }
     
      else{
      kan=m.find(b[i]);
      cout<<kan->second;
      }
      i++;
     }
     cout<<endl;
     return 0;
    }

  • 相关阅读:
    day15
    day13
    day12
    使用modelsim直接仿真IP(FIFO)
    整理:FPGA选型
    Quartus 中调用modelsim的流程及*.vt或*.vht自动生成
    quartus ip核破解
    LDO ,开关电源DC-DC的优缺点
    硬件工程师面试经历2015---笔试篇
    出色的硬件工程师必备的几项“硬”实力
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387825.html
Copyright © 2011-2022 走看看