zoukankan      html  css  js  c++  java
  • Babelfish

    Description

    You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

    Input

    Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

    Output

    Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

    Sample Input

    dog ogday
    cat atcay
    pig igpay
    froot ootfray
    loops oopslay
    
    atcay
    ittenkay
    oopslay
    

    Sample Output

    cat
    eh
    loops
    

    Hint

    Huge input and output,scanf and printf are recommended.
    #include <iostream>
    #include <iomanip>
    #include <string>
    using namespace std;
    char  ch1[100000][10],ch2[100000][10],s[10];
    int main(){int i=0,j,k=0,len;
     while (gets(s))
        {
            len=strlen(s); //获取字符串的长度
            if (len==0)
            {
                break;
            }
            for (i=0;s[i]!=' ';i++)
            {
                ch1[k][i]=s[i];
            }
            ch1[k][i]='';
            for (j=0;i+j+1<len;j++)
            {
                ch2[k][j]=s[i+j+1];
            }
            ch2[k][j]='';
       k++;
        }
    
    while(gets(s))
    {len=strlen(s); //获取字符串的长度
            if (len==0)
            {
                break;
            }
    	for(j=0;j<=i;j++)
    {if(j==i){cout<<"eh"<<endl;break;}
    
    if(strcmp(ch2[j],s)==0)
    {	cout<<ch1[j]<<endl;break;}
    
    }
    
    
    k++;}
    
    
    return 0;}

  • 相关阅读:
    C++常见错误大全(转)
    在字符串中删除特定字符
    C++ const 的全面总结
    函数返回局部变量问题
    TerminateThread()结束一个线程会有什么结果?
    小刘同学的第五十五篇博文
    小刘同学的五十、五一、五二博文断更…
    小刘同学的第五十三篇博文
    小刘同学的第四十九篇博文
    小刘同学的第四十八篇博文
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387829.html
Copyright © 2011-2022 走看看