zoukankan      html  css  js  c++  java
  • The Dole Queue

    Description

    Download as PDF


     The Dole Queue 

    In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

    Input

    Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

    Output

    For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

    Sample input

    10 4 3
    0 0 0

    Sample output

    tex2html_wrap_inline34 4 tex2html_wrap_inline34 8, tex2html_wrap_inline34 9 tex2html_wrap_inline34 5, tex2html_wrap_inline34 3 tex2html_wrap_inline34 1, tex2html_wrap_inline34 2 tex2html_wrap_inline34 6, tex2html_wrap_inline50 10, tex2html_wrap_inline34 7

    where tex2html_wrap_inline50 represents a space.

    #include <iostream>
    #include <iomanip>
    using namespace std;
    int a[1000];
    int main()
    {int n,l,r,i,j,k;
    while(cin>>n,n!=0)
    {int N=n;
    for(i=0;i<=n+1;i++)
    a[i]=0;
    cin>>l>>r;
    int q=0,p=n+1;
    while(N!=0)
    {
     for(j=1;j<=l;)
     {
      q++;
      if(q==n+1)q=1;
      if(a[q]!=1)j++;}
     
     for(k=1;k<=r;)
     { p--;
     
     if(p==0)p=n;
     if(a[p]!=1)k++;
     }
     a[q]=1;
     a[p]=1;
     if(q!=p){cout<<setw(3) <<q<<setw(3) <<p;N=N-2;}
     else if(q==p){cout<<setw(3) <<q;N--;}
     if(N!=0)cout<<",";
     else cout<<endl;
    }

    }
    return 0;

    }

    注意输出格式

  • 相关阅读:
    大厂的面试官是如何挑人的?
    搞懂这7个Maven问题,带你吊打面试官!
    Spring Cloud Eureka 注册安全一定要做到位!
    09 webpack的介绍
    08 node.js 的使用
    07 Node.js安装及环境配置
    06-Nodejs介绍
    05-面向对象
    Mysql 的使用方法
    04-对象的单体模式
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387832.html
Copyright © 2011-2022 走看看