zoukankan      html  css  js  c++  java
  • Adding Reversed Numbers

    Description

    The Antique Comedians of Malidinesia prefer comedies to tragedies. Unfortunately, most of the ancient plays are tragedies. Therefore the dramatic advisor of ACM has decided to transfigure some tragedies into comedies. Obviously, this work is very hard because the basic sense of the play must be kept intact, although all the things change to their opposites. For example the numbers: if any number appears in the tragedy, it must be converted to its reversed form before being accepted into the comedy play.

    Reversed number is a number written in arabic numerals but the order of digits is reversed. The first digit becomes last and vice versa. For example, if the main hero had 1245 strawberries in the tragedy, he has 5421 of them now. Note that all the leading zeros are omitted. That means if the number ends with a zero, the zero is lost by reversing (e.g. 1200 gives 21). Also note that the reversed number never has any trailing zeros.

    ACM needs to calculate with reversed numbers. Your task is to add two reversed numbers and output their reversed sum. Of course, the result is not unique because any particular number is a reversed form of several numbers (e.g. 21 could be 12, 120 or 1200 before reversing). Thus we must assume that no zeros were lost by reversing (e.g. assume that the original number was 12).


    Input



    The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line with two positive integers separated by space. These are the reversed numbers you are to add.


    Output



    For each case, print exactly one line containing only one integer - the reversed sum of two reversed numbers. Omit any leading zeros in the output.


    Sample Input



    3
    24 1
    4358 754
    305 794


    Sample Output



    34
    1998
    1






















    #include<iostream>
    using namespace std;
    int c[100];


    int huan1(int x)
    {int i=1,j,s1=0,k;
        while(x>0)
    {c[i]=x%10;
        x=x/10;

    i++;
    }
    j=i-1;k=1;
    while(j!=0)
    {s1=s1+c[j]*k;
    k=k*10;
    j--;
    }
    return s1;
    }



    int main()
    {int a1,b1,t,c1;
    cin>>t;
    while(t--)
    {cin>>a1>>b1;
    c1=huan1(a1)+huan1(b1);

    cout<<huan1(c1)<<endl;

    }

    return 0;}



  • 相关阅读:
    java泛型
    转载:MSIL Instruction Table
    What if your dynamic sql statement is too long?
    自己第一个正儿八经的div+css页面
    bulk insert formatFile格式记录
    日志 20071221(WCF,using keyword)
    C++点滴
    The scripts used to generate a demo "School" database (with data)
    The typical scenarios of using "Insert" in Tsql
    如何生成任意给定区间的随机值序列
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387835.html
Copyright © 2011-2022 走看看