zoukankan      html  css  js  c++  java
  • Red and Black

    Description

    There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

    Write a program to count the number of black tiles which he can reach by repeating the moves described above.

    Input

    The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

    There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

    '.' - a black tile
    '#' - a red tile
    '@' - a man on a black tile(appears exactly once in a data set)
    The end of the input is indicated by a line consisting of two zeros.

    Output

    For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

    Sample Input

    6 9
    ....#.
    .....#
    ......
    ......
    ......
    ......
    ......
    #@...#
    .#..#.
    11 9
    .#.........
    .#.#######.
    .#.#.....#.
    .#.#.###.#.
    .#.#..@#.#.
    .#.#####.#.
    .#.......#.
    .#########.
    ...........
    11 6
    ..#..#..#..
    ..#..#..#..
    ..#..#..###
    ..#..#..#@.
    ..#..#..#..
    ..#..#..#..
    7 7
    ..#.#..
    ..#.#..
    ###.###
    ...@...
    ###.###
    ..#.#..
    ..#.#..
    0 0

    Sample Output

    45
    59
    6
    13
    
    
    
    
    #include <iostream>
    using namespace std;
    char a[100][100];
    
    int p(char a[100][100],int x,int y)
    {int l=0;
    if(a[x-1][y]=='.')
    {a[x-1][y]='1';p(a,x-1,y);l=1;}
    if(a[x+1][y]=='.')
    {a[x+1][y]='1';p(a,x+1,y);l=1;}
    if(a[x][y-1]=='.')
    {a[x][y-1]='1';p(a,x,y-1);l=1;}
    if(a[x][y+1]=='.')
    {a[x][y+1]='1';p(a,x,y+1);l=1;}
    if(l==0)
    return 0;
    }
    
    
    int main()
    {int a1,a2,b1,b2,i,j;
    while(cin>>a2>>a1,a2!=0)
    {for(i=1;i<=a1;i++)
    for(j=1;j<=a2;j++)
    {cin>>a[i][j];
    if(a[i][j]=='@')
    {b1=i;b2=j;}
    }
    for(i=0;i<=a1;i++)
    {a[i][a2+1]='#';
    a[i][0]='#';}
    for(i=0;i<=a2;i++)
    {a[a1+1][i]='#';
    a[0][i]='#';}
    p(a,b1,b2);
    int count=0;
    for(i=1;i<=a1;i++)
    for(j=1;j<=a2;j++)
    {if(a[i][j]=='1')
    count++;}
    
    cout<<count+1<<endl;
    
    
    }
    
    return 0;}
     
  • 相关阅读:
    已经二叉树的前序遍历和中序遍历 写出后序遍历算法
    Windows GVim
    PHP PDO
    Html5 Geolocation获取地理位置信息
    Vim字符编码/中文乱码详解
    Vim常用操作命令
    三列布局,左右宽度固定,中间一列随浏览器窗口变化宽度
    Html5 跨域通信
    Http 与 Socket 区别
    浏览器对比不应该成为月经帖或季度帖
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387839.html
Copyright © 2011-2022 走看看