zoukankan      html  css  js  c++  java
  • Ride to School

    Description

    Many graduate students of Peking University are living in Wanliu Campus, which is 4.5 kilometers from the main campus – Yanyuan. Students in Wanliu have to either take a bus or ride a bike to go to school. Due to the bad traffic in Beijing, many students choose to ride a bike.

    We may assume that all the students except "Charley" ride from Wanliu to Yanyuan at a fixed speed. Charley is a student with a different riding habit – he always tries to follow another rider to avoid riding alone. When Charley gets to the gate of Wanliu, he will look for someone who is setting off to Yanyuan. If he finds someone, he will follow that rider, or if not, he will wait for someone to follow. On the way from Wanliu to Yanyuan, at any time if a faster student surpassed Charley, he will leave the rider he is following and speed up to follow the faster one.

    We assume the time that Charley gets to the gate of Wanliu is zero. Given the set off time and speed of the other students, your task is to give the time when Charley arrives at Yanyuan.

    Input

    There are several test cases. The first line of each case is N (1 <= N <= 10000) representing the number of riders (excluding Charley). N = 0 ends the input. The following N lines are information of N different riders, in such format:

    Vi [TAB] Ti

    Vi is a positive integer <= 40, indicating the speed of the i-th rider (kph, kilometers per hour). Ti is the set off time of the i-th rider, which is an integer and counted in seconds. In any case it is assured that there always exists a nonnegative Ti.

    Output

    Output one line for each case: the arrival time of Charley. Round up (ceiling) the value when dealing with a fraction.

    Sample Input

    4
    20	0
    25	-155
    27	190
    30	240
    2
    21	0
    22	34
    0
    

    Sample Output

    780
    771
    
    
    
    
    
    #include <iostream>
    #include <cmath>
    
    using namespace std;
    int main()
    {int t,i;
    double j,k;
    while(cin>>t,t!=0)
    {double a,b;
    j=4.5*3600;
    for(i=0;i<t;i++)
    {cin>>a>>b;
    if(b<0)continue;
    k=4.5/a*3600+b;
    if(k<=j)
    j=k;
    
    
    
    }
    
    
    cout<<ceil(j)<<endl;
    
    }
    
    
    
    return 0;
    
    
    
    }
    ——》》》》》》》》》》
    这个题就是求用的最少时间的那个;(排除先走的)
    1..如果刚开始走到是速度是慢的,,后来跟了一速度快的,用的时间就是速度快的那个人用的时间,并且他用的时间最少。


     

  • 相关阅读:
    Ansible 实战之部署Web架构
    Ansible Ad-Hoc命令集
    Ansible 基础知识
    memcached监控脚本
    Django2.1.1与xadmin0.6.0遇到的坑(一)
    django1.11 启动错误:Generator expression must be parenthesized
    使用Git Bash从Git上下载代码到本地以及上传代码到码云Git
    PyCharm如何导入python项目,并配置虚拟环境
    PYTHON中的字典(DICT),列表(LIST),元组(TUPLE)
    python2 和 python3共存的常见使用(如安装虚拟环境的问题)
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387845.html
Copyright © 2011-2022 走看看