zoukankan      html  css  js  c++  java
  • Doubles

    B - Doubles(1.2.1)
    Time Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u

    Description

    As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list
    1 4 3 2 9 7 18 22

    your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

    Input

    The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

    Output

    The output will consist of one line per input list, containing a count of the items that are double some other item.

    Sample Input

    1 4 3 2 9 7 18 22 0
    2 4 8 10 0
    7 5 11 13 1 3 0
    -1

    Sample Output

    3
    2
    0
    
    
    #include <iostream>
    #include <stdlib.h>
    using namespace std;
    int main()
    {
    	int a[100];
    
    while(cin>>a[0]&&a[0]!=-1)
    {int i,n=1,j,k;
    while(cin>>i&&i!=0)
    {a[n]=i;
    n++;}
    for(i=0;i<n;i++)
        for(j=i;j<n;j++)
    {if(a[i]>a[j])
    	{k=a[j];
    a[j]=a[i];
    a[i]=k;
        }
    }
    k=0;
    for(j=0;j<n;j++)
    for(i=0;i<j;i++)
    {if(a[i]*2==a[j])
            k++;}
            cout<<k<<endl;
    
    }
    return 0;
    
    }

  • 相关阅读:
    JavaScript Object.prototype.toString 解析过程
    今天一定要纪念一下
    考验你的JavaScript底细
    2016-3-23
    记录一下最近的感受
    mac ox快捷键总结
    如何把开源的项目fork到自己的仓库并Down到本地
    使用vue-cli构建vue.js项目
    成为一名优秀的web前端工程师都需要做些什么?
    关于angularjs input上传图片前获取图片的Size 浅析
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387857.html
Copyright © 2011-2022 走看看