zoukankan      html  css  js  c++  java
  • Super Jumping! Jumping! Jumping!

    Problem Description

    Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



    The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
    Your task is to output the maximum value according to the given chessmen list.

    Input

    Input contains multiple test cases. Each test case is described in a line as follow:
    N value_1 value_2 …value_N
    It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
    A test case starting with 0 terminates the input and this test case is not to be processed.

    Output

    For each case, print the maximum according to rules, and one line one case.

    Sample Input

    3 1 3 2
    4 1 2 3 4
    4 3 3 2 1
    0
    

    Sample Output

    4
    10
    3
    

    Author

    lcy
     
     
     
     
     
     
     
     
     
     
     
     

    #include <iostream>
    #include<algorithm>
    using namespace std;
    int a[1000],b[1000];
    int main()
    {int i,n,j;

        while(cin>>n&&n!=0)
    {
            int s=0;
       
        for(i=0;i<n;i++)
            cin>>a[i];
        for(i=0;i<n;i++)
        {b[i]=a[i];
            for(j=0;j<i;j++)
            if(a[i]>a[j]&&b[i]<b[j]+a[i])
            { b[i]=b[j]+a[i];
            s=b[0];}}
          for(i=0;i<n;i++)
              if(b[i]>s)
                  s=b[i];
              cout<<s<<endl;


    }
    return 0;
    }

  • 相关阅读:
    【SPOJ 104】Highways
    Test_Codes
    【关路灯】【MM不哭】
    省选悲剧
    【HNOI 2002】营业额统计
    博弈论 Nimm Games
    【NOI 2008】志愿者招募 Employee
    【APIO2009】ATM
    【SDOI 2009】学校食堂 Dining
    POJ 1001
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387864.html
Copyright © 2011-2022 走看看