zoukankan      html  css  js  c++  java
  • Common Subsequence

    Common Subsequence

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
    Total Submission(s) : 32   Accepted Submission(s) : 16

    Font: Times New Roman | Verdana | Georgia

    Font Size:

    Problem Description

    A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
    The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

    Sample Input

    abcfbc abfcab
    programming contest 
    abcd mnp
    

    Sample Output

    4
    2
    0
    

    Source

    Southeastern Europe 2003

    #include <iostream>
    #include<string>
    using namespace std;
    char d[1000],p[1000];
    int a[1000][1000];

    int main()
    {int i,j,d2,d1;
        while(cin>>d>>p)
        {d1=strlen(d);
        d2=strlen(p);
    for(i=0;i<d1;i++)
    for(j=0;j<d2;j++)
    a[i][j]=0;
            for(i=1;i<strlen(d)+1;i++)
    for(j=1;j<strlen(p)+1;j++)
    {if(d[i-1]==p[j-1])
    a[i][j]=a[i-1][j-1]+1;
    else
    a[i][j]=a[i-1][j]>a[i][j-1]?a[i-1][j]:a[i][j-1];

    }


    cout<<a[d1][d2]<<endl;

        }
        return 0;
    }

  • 相关阅读:
    初涉echarts图表笔记。
    es6----数组去重(简单类型和引用类型)
    git pull 拉取更新失败解决方案
    javascript----是否下拉到页面底部
    构造函数和析构函数
    派生类和基类
    C++11新标准
    类型转换
    编码
    牛牛的背包问题
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387865.html
Copyright © 2011-2022 走看看