zoukankan      html  css  js  c++  java
  • Heritage from father

    http://acm.hdu.edu.cn/diy/contest_showproblem.php?pid=1006&cid=22619


    Problem Description

    Famous Harry Potter,who seemd to be a normal and poor boy,is actually a wizard.Everything changed when he had his birthday of ten years old.A huge man called 'Hagrid' found Harry and lead him to a new world full of magic power. 
    If you've read this story,you probably know that Harry's parents had left him a lot of gold coins.Hagrid lead Harry to Gringotts(the bank hold up by Goblins). And they stepped into the room which stored the fortune from his father.Harry was astonishing ,coz there were piles of gold coins. 
    The way of packing these coins by Goblins was really special.Only one coin was on the top,and three coins consisted an triangle were on the next lower layer.The third layer has six coins which were also consisted an triangle,and so on.On the ith layer there was an triangle have i coins each edge(totally i*(i+1)/2).The whole heap seemed just like a pyramid.Goblin still knew the total num of the layers,so it's up you to help Harry to figure out the sum of all the coins.

    Input

    The input will consist of some cases,each case takes a line with only one integer N(0<N<2^31).It ends with a single 0.

    Output

    对于每个输入的N,输出一行,采用科学记数法来计算金币的总数(保留三位有效数字)

    Sample Input

    1
    3
    0
    

    Sample Output

    1.00E0
    1.00E1
    

    Hint

    Hint
    when N=1 ,There is 1 gold coins. 
    when N=3 ,There is 1+3+6=10 gold coins.

    Source

    Gardon-DYGG Contest 1



    #include<iostream>
    #include <iomanip>
    #include <cmath>
    using namespace std;
    int main()
    {
        int a,b;
        double c,d;
        while(cin>>a)
        {
            if(a==0) break;
            d = a;
            c = log10(d/6)+log10(d+1)+log10(d+2);
            b = int(c);
            cout<<fixed<<setprecision(2)<<pow(10.0,c-b)<<'E'<<b<<endl;
        }
        return 0;

  • 相关阅读:
    Android中fragment之间和Activity的传值、切换
    javascript--经典实例锦集
    Android中ListView动态加载数据
    Android开发之调用系统图库及相机
    Android 相机开发详解
    RTSP实例解析
    【Android UI设计与开发】第18期:滑动菜单栏(三)SlidingMenu动画效果的实现
    js 第二小步
    JavaScript初步+基本函数
    javaweb实战开始
  • 原文地址:https://www.cnblogs.com/lengxia/p/4387884.html
Copyright © 2011-2022 走看看