zoukankan      html  css  js  c++  java
  • HDU1728 逃离迷宫【BFS】

    逃离迷宫

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 18148    Accepted Submission(s): 4388


    Problem Description
      给定一个m × n (m行, n列)的迷宫,迷宫中有两个位置,gloria想从迷宫的一个位置走到另外一个位置,当然迷宫中有些地方是空地,gloria可以穿越,有些地方是障碍,她必须绕行,从迷宫的一个位置,只能走到与它相邻的4个位置中,当然在行走过程中,gloria不能走到迷宫外面去。令人头痛的是,gloria是个没什么方向感的人,因此,她在行走过程中,不能转太多弯了,否则她会晕倒的。我们假定给定的两个位置都是空地,初始时,gloria所面向的方向未定,她可以选择4个方向的任何一个出发,而不算成一次转弯。gloria能从一个位置走到另外一个位置吗?
     
    Input
      第1行为一个整数t (1 ≤ t ≤ 100),表示测试数据的个数,接下来为t组测试数据,每组测试数据中,
      第1行为两个整数m, n (1 ≤ m, n ≤ 100),分别表示迷宫的行数和列数,接下来m行,每行包括n个字符,其中字符'.'表示该位置为空地,字符'*'表示该位置为障碍,输入数据中只有这两种字符,每组测试数据的最后一行为5个整数k, x1, y1, x2, y2 (1 ≤ k ≤ 10, 1 ≤ x1, x2 ≤ n, 1 ≤ y1, y2 ≤ m),其中k表示gloria最多能转的弯数,(x1, y1), (x2, y2)表示两个位置,其中x1,x2对应列,y1, y2对应行。
     
    Output
      每组测试数据对应为一行,若gloria能从一个位置走到另外一个位置,输出“yes”,否则输出“no”。
     
    Sample Input
    2 5 5 ...** *.**. ..... ..... *.... 1 1 1 1 3 5 5 ...** *.**. ..... ..... *.... 2 1 1 1 3
     
    Sample Output
    no yes
     
     

    #include <iostream>
    #include <queue>
    #include<cstring>
    using namespace std;
    struct node
    {
        int x,y,t;
    };
    int vis[101][101];
    char map[101][101];
    int step[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};
    int x,y,x1,y1,n,m,k;
    bool  bfs()
    {
        memset(vis,0,sizeof(vis));
        queue<node> q;
        node now;
        now.x=x;
        now.y=y;
        now.t=-1;
        q.push(now);
        vis[x][y]=1;
        while(!q.empty())
        {
            now=q.front();
            q.pop();
            node next;
            if(now.t>=k)continue;
            for(int i=0; i<4; i++)
            {
                next.x=now.x+step[i][0];
                next.y=now.y+step[i][1];
                next.t=now.t+1;

                while(1)
                {
                    if(next.x<0||next.x>=m||next.y<0||next.y>=n)
                        break;
                    if(map[next.x][next.y]=='*')
                        break;
                    if(next.x==x1&&next.y==y1)
                        return 1;
                    if(!vis[next.x][next.y])
                    {
                        q.push(next);
                        vis[next.x][next.y]=1;
                    }
                    next.x+=step[i][0];
                    next.y+=step[i][1];
                }
            }
        }
        return 0;
    }


    int main()
    {
        int t;
        cin>>t;
        while(t--)
        {
            cin>>m>>n;
            for(int i=0; i<m; i++)
                cin>>map[i];
            cin>>k>>y>>x>>y1>>x1;
            x--;
            y--;
            x1--;
            y1--;
            if(bfs())
                cout<<"yes"<<endl;
            else cout<<"no"<<endl;
        }
        return 0;
    }

  • 相关阅读:
    C++ 从文件中读取数据的代码及优化
    EOF在C++中的含义
    利用"中值滤波原理"过滤异常数据(转载)
    Hive差集运算详解
    H5 玩出新花样(一) -- 森林领导术不倒流
    C++中怎么暂停几秒
    c语言中 srand(time(NULL)); 这句话是什么意思(尤其是 NULL)
    C++ 码代码的风格(推荐)
    c/c++编译器的安装
    jquery的$(selector).each,$.each的区别
  • 原文地址:https://www.cnblogs.com/lengxia/p/4472442.html
Copyright © 2011-2022 走看看